summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-14 07:47:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-14 10:03:17 +0200
commit171db9b414d775355d0b65cb968145d8a5b3726b (patch)
tree17ace1d0ad40ff096a1adc1c9ff02b8e6956557e /dev-python/zeroconf
parentdev-python/dask: Bump to 2021.8.0 (diff)
downloadgentoo-171db9b414d775355d0b65cb968145d8a5b3726b.tar.gz
gentoo-171db9b414d775355d0b65cb968145d8a5b3726b.tar.bz2
gentoo-171db9b414d775355d0b65cb968145d8a5b3726b.zip
dev-python/zeroconf: Bump to 0.35.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.35.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 18676cee6bfa..6be000ec3bfd 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -4,3 +4,4 @@ DIST python-zeroconf-0.33.3.gh.tar.gz 121202 BLAKE2B f457a65d26b58e4dac6c83b66be
DIST python-zeroconf-0.33.4.gh.tar.gz 121380 BLAKE2B a1a8ac266aaded65337aa9d5c26d8a52b6329500a1a18354148590fdb47988f200b0658a41e18b78694cd9f95f1322cce0ff289a795bf9459ab6d383d5ee13f9 SHA512 fa6dd453ea22beb113c53941ce750e214da3211b6fc14d8b0cb575b927cff14759c49fec4e9ada4a2fd4ebc0bb3b0b355a2454ca0e128a3213fc8be41f096af7
DIST python-zeroconf-0.34.2.gh.tar.gz 125452 BLAKE2B 704ab1400a01eae93b1f706c2ccd4554b7ffbbcfcaebfc28bacf6e28354894185a7ed5cffddb3b96ff05dc3521d2507160a5f43c11a600c5b5043882d15c39e6 SHA512 958d01316ef307d08d68abe975f45d77e84cede8334f8ad023080b7d46f965f890b1c74de640807681d3aaa647e01902de01309e3520fba8ba18cb4b6af1f4ba
DIST python-zeroconf-0.34.3.gh.tar.gz 125454 BLAKE2B d80c25fa8bb79b6c5a3d491efc0e891b08e808d9c2619d917a19d9d76ebdf13d32ddb684a3f68abd7ae6dce3597de30027557033a5ccacfe8dcc5bf624b45f25 SHA512 d9f1ab126dd68fdef2e2983a11efe7d3703bbacd7b74b9a82a781361b0282bf20d8c16bcf96beda7112958eab54e0b819f709d840a9e5f0f2da8c9003e9943fe
+DIST python-zeroconf-0.35.0.gh.tar.gz 126620 BLAKE2B 1c2a7e78c32305be0c35fcef513e26c1834dee71b7714479c70c44a09378fb96a15f39fb4d9de4a8bde607cc4ef67798b5e6cb09e613f1a86cd9934123ab2ca9 SHA512 440871dd5fa861950187bf0c4593b2212d91477d4adbd41a43fd3adec820543628d684dfc042e38e4b69cd94e8b23d10298e660da32f8c221faf16e03135b925
diff --git a/dev-python/zeroconf/zeroconf-0.35.0.ebuild b/dev-python/zeroconf/zeroconf-0.35.0.ebuild
new file mode 100644
index 000000000000..0e1b2943b16e
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.35.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local excludes=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+ )
+
+ epytest ${excludes[@]/#/--deselect }
+}