summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-04 13:35:43 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-04 13:36:58 +0100
commit0422aea7955cee23cb3ca03b80441186a29b93db (patch)
treec35daf403a42e895e054efdbcfa2a8fd2512e461 /dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild
parentRevert "dev-python/zope-component: Remove namespace dep" (diff)
downloadgentoo-0422aea7955cee23cb3ca03b80441186a29b93db.tar.gz
gentoo-0422aea7955cee23cb3ca03b80441186a29b93db.tar.bz2
gentoo-0422aea7955cee23cb3ca03b80441186a29b93db.zip
Revert "dev-python/zope-deprecation: Remove namespace dep"
This reverts commit 3128e7beecd38f1f191713c23ff933f5b64a5fdd. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild')
-rw-r--r--dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild b/dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild
new file mode 100644
index 000000000000..e0d43587ae93
--- /dev/null
+++ b/dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..8} pypy3 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope Deprecation Infrastructure"
+HOMEPAGE="https://github.com/zopefoundation/zope.deprecation"
+SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${ED}" -name '*.pth' -delete || die
+}