summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-11-13 13:37:48 +0200
committerMichał Górny <mgorny@gentoo.org>2019-11-30 09:28:06 +0100
commit2a4001b2302ce29f1cd71c99e0a9756dd90e7468 (patch)
treeae170e9ab16e6cbac58f857ec0f36969458c595c /dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild
parentdev-python/zope-schema: bump v4.9.3, EAPI=7 (diff)
downloadgentoo-2a4001b2302ce29f1cd71c99e0a9756dd90e7468.tar.gz
gentoo-2a4001b2302ce29f1cd71c99e0a9756dd90e7468.tar.bz2
gentoo-2a4001b2302ce29f1cd71c99e0a9756dd90e7468.zip
dev-python/zope-deprecation: bump v4.4.0, EAPI=7
add python3_8 use distutils_enable_tests for tests Closes: https://bugs.gentoo.org/459494 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild')
-rw-r--r--dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild b/dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild
new file mode 100644
index 000000000000..9932b793cd1c
--- /dev/null
+++ b/dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope Deprecation Infrastructure"
+HOMEPAGE="https://github.com/zopefoundation/zope.deprecation"
+SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${ED}" -name '*.pth' -delete || die
+}