summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-21 04:06:58 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-21 04:15:52 -0400
commit8e71f2dd9f195c0b743256975e0c9306868479ac (patch)
treee0eb771d4092c7efde11a8c79298a1001d719e4f /dev-python/zope-interface/zope-interface-4.2.0.ebuild
parentdev-python/zope-event: add keywords for zope-interface test dep (diff)
downloadgentoo-8e71f2dd9f195c0b743256975e0c9306868479ac.tar.gz
gentoo-8e71f2dd9f195c0b743256975e0c9306868479ac.tar.bz2
gentoo-8e71f2dd9f195c0b743256975e0c9306868479ac.zip
dev-python/zope-interface: version bump to 4.2.0
Diffstat (limited to 'dev-python/zope-interface/zope-interface-4.2.0.ebuild')
-rw-r--r--dev-python/zope-interface/zope-interface-4.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/zope-interface/zope-interface-4.2.0.ebuild b/dev-python/zope-interface/zope-interface-4.2.0.ebuild
new file mode 100644
index 000000000000..c3e1d43e2d5c
--- /dev/null
+++ b/dev-python/zope-interface/zope-interface-4.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Interfaces for Python"
+HOMEPAGE="https://pypi.python.org/pypi/zope.interface https://github.com/zopefoundation/zope.interface"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/zope-event[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+ append-flags -fno-strict-aliasing
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}