summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-16 06:53:55 +0000
committerSam James <sam@gentoo.org>2020-08-18 14:58:56 +0000
commitd50cae8bcd0f72a470e41b31ea6b65738ad96d6d (patch)
tree60675f97d92764af15f28be7ceaa995f731d8b59 /dev-python/zope-schema/zope-schema-6.0.0.ebuild
parentdev-python/zope-testrunner: bump to 5.2 (diff)
downloadgentoo-d50cae8bcd0f72a470e41b31ea6b65738ad96d6d.tar.gz
gentoo-d50cae8bcd0f72a470e41b31ea6b65738ad96d6d.tar.bz2
gentoo-d50cae8bcd0f72a470e41b31ea6b65738ad96d6d.zip
dev-python/zope-schema: bump to 6.0.0
Add Python 3.9 support. Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/zope-schema/zope-schema-6.0.0.ebuild')
-rw-r--r--dev-python/zope-schema/zope-schema-6.0.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/zope-schema/zope-schema-6.0.0.ebuild b/dev-python/zope-schema/zope-schema-6.0.0.ebuild
new file mode 100644
index 000000000000..a1f94c6b6f3d
--- /dev/null
+++ b/dev-python/zope-schema/zope-schema-6.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope schema Architecture"
+HOMEPAGE="https://github.com/zopefoundation/zope.schema http://docs.zope.org/zope.schema/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="dev-python/zope-event[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-5.0.0[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ dev-python/zope-i18nmessageid[${PYTHON_USEDEP}]
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ dev-python/zope-testrunner[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # remove .pth files since dev-python/namespace-zope handles the ns
+ find "${D}" -name '*.pth' -delete || die
+}