summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-29 20:11:02 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-29 20:11:02 -0400
commit5c4955545b7c74eb0876f59a0fe7ef5f963f2c60 (patch)
tree303c2bf5fc20c2543da6c3e7c7ee20a2615b71aa /dev-python/zope-testrunner/zope-testrunner-4.7.0.ebuild
parentdev-python/zope-testing: version bump to 4.6.2 (diff)
downloadgentoo-5c4955545b7c74eb0876f59a0fe7ef5f963f2c60.tar.gz
gentoo-5c4955545b7c74eb0876f59a0fe7ef5f963f2c60.tar.bz2
gentoo-5c4955545b7c74eb0876f59a0fe7ef5f963f2c60.zip
dev-python/zope-testrunner: version bump to 4.7.0
Diffstat (limited to 'dev-python/zope-testrunner/zope-testrunner-4.7.0.ebuild')
-rw-r--r--dev-python/zope-testrunner/zope-testrunner-4.7.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/zope-testrunner/zope-testrunner-4.7.0.ebuild b/dev-python/zope-testrunner/zope-testrunner-4.7.0.ebuild
new file mode 100644
index 000000000000..99f2b933baa6
--- /dev/null
+++ b/dev-python/zope-testrunner/zope-testrunner-4.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope testrunner script"
+HOMEPAGE="https://pypi.python.org/pypi/zope.testrunner https://github.com/zopefoundation/zope.testrunner"
+SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# TODO: extras?
+RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/zope-exceptions[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ # some tests rely on .pyc files being present
+ local -x PYTHONDONTWRITEBYTECODE=
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # remove .pth files since dev-python/namespace-zope handles the ns
+ find "${D}" -name '*.pth' -delete || die
+}