summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-17 05:12:40 +0100
committerSam James <sam@gentoo.org>2021-07-17 05:13:28 +0100
commit008fadd363d9dd61c40e8620ff7cc6da2db3fc5d (patch)
treeae76b7a28f313407bfa59ea041e9a0bb5a054dfa /dev-python
parentdev-python/PyPDF2: update EAPI 6 -> 7, add Python 3.10 (diff)
downloadgentoo-008fadd363d9dd61c40e8620ff7cc6da2db3fc5d.tar.gz
gentoo-008fadd363d9dd61c40e8620ff7cc6da2db3fc5d.tar.bz2
gentoo-008fadd363d9dd61c40e8620ff7cc6da2db3fc5d.zip
dev-python/libarchive-c: run tests, add Python 3.10
Closes: https://bugs.gentoo.org/798090 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/libarchive-c/libarchive-c-2.9.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/libarchive-c/libarchive-c-2.9.ebuild b/dev-python/libarchive-c/libarchive-c-2.9.ebuild
index 836c869f14ab..be0363504712 100644
--- a/dev-python/libarchive-c/libarchive-c-2.9.ebuild
+++ b/dev-python/libarchive-c/libarchive-c-2.9.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A Python interface to libarchive"
@@ -13,6 +13,8 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="CC0-1.0"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE=""
RDEPEND="app-arch/libarchive"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest