summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-30 08:08:55 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-30 08:08:55 +0200
commit0123761cb8fbc32d8357c25075102302e41997a1 (patch)
treebcda7087062216888ddcb40507e18cf5f3a135b7 /dev-python
parentdev-python/python-jose: Bump to 3.2.0 (diff)
downloadgentoo-0123761cb8fbc32d8357c25075102302e41997a1.tar.gz
gentoo-0123761cb8fbc32d8357c25075102302e41997a1.tar.bz2
gentoo-0123761cb8fbc32d8357c25075102302e41997a1.zip
dev-python/sybil: Bump to 1.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/sybil-1.3.1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index ec1c3a37690d..2a6acc4ef5e2 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,2 +1,3 @@
DIST sybil-1.2.2.tar.gz 29182 BLAKE2B d0d9a0a2e5117efd36e7561f74d31283fa25ea0210e0796fe1a1cc4247712bff0e3ac329781987b5ba805ccd2cddf01eec2672d5e2677422d1ed378068482da5 SHA512 c1785c00ce1dfdaf85d13db976f28062c09c47974107bc2af54c3bd9bf4ad5124c9b52321f3350fb1cc50aefdf72f2a9b6b22fc766b139516ff7979864604735
DIST sybil-1.3.0.tar.gz 29296 BLAKE2B a7f08f6374e12213b644685276832eca849c85e85c8aaf0a37bdfdbf648e0e0e4c2b3d1a4dc7038c91fe8d64aa476d96bf87fa3a5f2f11a955b758182411763d SHA512 fc478896bb1958303ffcac6d35993b2785a50c6c221848d83c92c158a27fff059491aa3baaddd0b56e040fe6c07b764aa33c69204750de9ad351084b2815fd47
+DIST sybil-1.3.1.tar.gz 29392 BLAKE2B a7736bed59e444bcd42f5fdf720e08680d827eef9043b318abda08d427e25eeec9ba3acf9bfa251c584e0960c3d3b10fecaf8367742f29230421bec594cf3e59 SHA512 7bd39707babb15ed7ec99ecd640d983d4e71519efe7490230fe0be4e0111bc0b0957797b19292519b6c09965669251788f1d2c0baf9f179856f28e6aeb5ecc52
diff --git a/dev-python/sybil/sybil-1.3.1.ebuild b/dev-python/sybil/sybil-1.3.1.ebuild
new file mode 100644
index 000000000000..3918a42c35cd
--- /dev/null
+++ b/dev-python/sybil/sybil-1.3.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="https://github.com/cjw296/sybil"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# nose is used to test nosetests integration
+BDEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest