summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-18 10:11:53 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-18 10:51:38 +0100
commit02964c42a225eb98bf54ac9460d86287311a40a8 (patch)
tree5cd82db682fc0579595c91818d646908e2f0c225 /dev-python
parentdev-python/pytest-asyncio: Bump to 0.17.2 (diff)
downloadgentoo-02964c42a225eb98bf54ac9460d86287311a40a8.tar.gz
gentoo-02964c42a225eb98bf54ac9460d86287311a40a8.tar.bz2
gentoo-02964c42a225eb98bf54ac9460d86287311a40a8.zip
dev-python/debtcollector: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/debtcollector/Manifest1
-rw-r--r--dev-python/debtcollector/debtcollector-2.4.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/debtcollector/Manifest b/dev-python/debtcollector/Manifest
index 89eb4b3c3cfd..889e03b196c5 100644
--- a/dev-python/debtcollector/Manifest
+++ b/dev-python/debtcollector/Manifest
@@ -1 +1,2 @@
DIST debtcollector-2.3.0.tar.gz 31537 BLAKE2B 6c4993edf08dd72e8378bd82e4578a491f0540d35165e3c67e918ef5a659de06e4fd83d2737458cddd27ef08dfd01a38679b940e80a4b460e145ab20789940e5 SHA512 d8a9a65ec33bf6bc777d6766842cd6351c265752f552bda3bfd1db86a08c8c89c3f871c6eff15648a8c1a79d7820368711256d404934fd826ee6cb0c7c53f77a
+DIST debtcollector-2.4.0.tar.gz 31376 BLAKE2B ccd34005133a888b164538c01ed482da26e91e2dd5d9f11bb0efacc0941c9eb1c0357ce8d0c237734ad450226512263ba8aa52f3b8e712a33a40fac384db2791 SHA512 31287e223524d5997e9dc776766c5ab2ec77c771fca6e9b27e058fdd94a20b67a73147c538f9a7a3155c4ce6eb85a20e8276bedd1a53a81bebcb5daaceb1b463
diff --git a/dev-python/debtcollector/debtcollector-2.4.0.ebuild b/dev-python/debtcollector/debtcollector-2.4.0.ebuild
new file mode 100644
index 000000000000..fdd005b4f461
--- /dev/null
+++ b/dev-python/debtcollector/debtcollector-2.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python deprecation patterns and strategies that collect technical debt"
+HOMEPAGE="https://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/subunit[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest