summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-16 23:33:16 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-16 23:39:49 +0200
commit02f69dc1097032a433821834c4e37d4f9f80d5a4 (patch)
treea346f22e3df55f18d2a1f0b85b3bae1df838bcd3 /dev-python
parentdev-python/pylint: Fix running *all* tests (diff)
downloadgentoo-02f69dc1097032a433821834c4e37d4f9f80d5a4.tar.gz
gentoo-02f69dc1097032a433821834c4e37d4f9f80d5a4.tar.bz2
gentoo-02f69dc1097032a433821834c4e37d4f9f80d5a4.zip
dev-python/pylint: Disarm unused pytest-runner dep, #618666
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylint/pylint-1.7.1-r1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/pylint/pylint-1.7.1-r1.ebuild b/dev-python/pylint/pylint-1.7.1-r1.ebuild
index a26d98dcba57..4aa65c9ed878 100644
--- a/dev-python/pylint/pylint-1.7.1-r1.ebuild
+++ b/dev-python/pylint/pylint-1.7.1-r1.ebuild
@@ -34,6 +34,13 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}] )"
+python_prepare_all() {
+ # remove unused dep
+ sed -i -e '/pytest-runner/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
python_compile_all() {
# selection of straight html triggers a trivial annoying bug, we skirt it
use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml