summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-18 22:58:29 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-18 23:44:24 +0100
commit0544d26e7d4fd91ff3167b90df7c99670f88fba5 (patch)
treeddd22b54c06c4c1df0832dba4f066454dc9a3abd /dev-python
parentdev-python/regex: Bump to 2022.1.18 (diff)
downloadgentoo-0544d26e7d4fd91ff3167b90df7c99670f88fba5.tar.gz
gentoo-0544d26e7d4fd91ff3167b90df7c99670f88fba5.tar.bz2
gentoo-0544d26e7d4fd91ff3167b90df7c99670f88fba5.zip
dev-python/entrypoint2: Bump to 1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/entrypoint2/Manifest1
-rw-r--r--dev-python/entrypoint2/entrypoint2-1.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/entrypoint2/Manifest b/dev-python/entrypoint2/Manifest
index 6d18e06b6d2f..6f410593def0 100644
--- a/dev-python/entrypoint2/Manifest
+++ b/dev-python/entrypoint2/Manifest
@@ -1 +1,2 @@
DIST entrypoint2-0.2.4.tar.gz 10407 BLAKE2B 16335f8e2bc173413f387e581892b1fe03efdb6bdea2e75d20a95258d55c0cb83dc70691cb4b41b07e49881db4e5c08593bba42adf5c1a69785e32c99d68a7fa SHA512 7bf7dea2afc7df3ebe57f89f472e4456fc22d5c66720930a2b15dbe04f708ff4bb00feec79af430620d8cc6d91d5df1770869d23d2282ecc0024ecc7583b360b
+DIST entrypoint2-1.0.tar.gz 15424 BLAKE2B 1270a35218cde90922fe8f675917545f4c43e5ec0effd632583cd0bd02200d6a453716787c222722cec633bcb108c1b8c26e284e9659e754d3bc6a77895a6042 SHA512 6580dbf19482af95cbccad61b6f6dc73c068ac78d166e2cea4fae54243921e577316d38e204ad5983f0f52d898d67a10f4c90332d4eeaff1ea713bfc82c70890
diff --git a/dev-python/entrypoint2/entrypoint2-1.0.ebuild b/dev-python/entrypoint2/entrypoint2-1.0.ebuild
new file mode 100644
index 000000000000..9b2ed1b03eef
--- /dev/null
+++ b/dev-python/entrypoint2/entrypoint2-1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Easy to use command-line interface for python modules"
+HOMEPAGE="https://github.com/ponty/entrypoint2"
+SRC_URI="https://github.com/ponty/entrypoint2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/easyprocess[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest