summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2019-01-01 00:41:59 +0100
committerDavide Pesavento <pesa@gentoo.org>2019-01-01 00:44:15 +0100
commit0672876497645f8acce9ddd1e3523d2a242df3e0 (patch)
tree3ea600788490e6a17e4ed18989c5ffacb3ff5257 /dev-python
parentnet-analyzer/openvas-scanner: EAPI-7 bump (diff)
downloadgentoo-0672876497645f8acce9ddd1e3523d2a242df3e0.tar.gz
gentoo-0672876497645f8acce9ddd1e3523d2a242df3e0.tar.bz2
gentoo-0672876497645f8acce9ddd1e3523d2a242df3e0.zip
dev-python/qscintilla-python: remove 2.10.4
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/qscintilla-python/Manifest1
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.10.4.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/qscintilla-python/Manifest b/dev-python/qscintilla-python/Manifest
index 692c9be04f56..a3b924ad27c7 100644
--- a/dev-python/qscintilla-python/Manifest
+++ b/dev-python/qscintilla-python/Manifest
@@ -1,2 +1 @@
-DIST QScintilla_gpl-2.10.4.tar.gz 2721322 BLAKE2B df50dd0a34db96dd57147ddc399d4a30751b1bb4922dc1b8b3c3c1989e810937dc8345f92128e8a606b1edc04fde4b930a424ab8344818c9899c8fe496793a77 SHA512 dee6684f68173784d098931554c839a30e129b89f980cd9704f818c44eb7023199bd3682e4b342091fa3e0ce577ec576d34046477bdd1d7fc58ca5dd2ba947a3
DIST QScintilla_gpl-2.10.8.tar.gz 2736054 BLAKE2B 4bc7a2bc1974f8e10a96b7716a8e35d4854e9eeb8040734f99b796bddd9679ee2539f6517743689f9d7deff9ce523cdbb2f77ccd65eaadfc947dcc7a1337d918 SHA512 c0a216737dbda6bc390225196b37a43e4884c9cd67e6e81fc1b1b952683fe88dbfe7caf3c66d94a378f37502e1f08cbdf788426248e73f5f66ec65982b7652b5
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.10.4.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.10.4.ebuild
deleted file mode 100644
index dbc23b01d914..000000000000
--- a/dev-python/qscintilla-python/qscintilla-python-2.10.4.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit python-r1 qmake-utils
-
-MY_P=QScintilla_gpl-${PV/_pre/.dev}
-
-DESCRIPTION="Python bindings for QScintilla"
-HOMEPAGE="https://www.riverbankcomputing.com/software/qscintilla/intro"
-SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-IUSE="debug"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="
- ${PYTHON_DEPS}
- >=dev-python/sip-4.19:=[${PYTHON_USEDEP}]
- dev-python/PyQt5[gui,printsupport,widgets,${PYTHON_USEDEP}]
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtprintsupport:5
- dev-qt/qtwidgets:5
- ~x11-libs/qscintilla-${PV}:=
-"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}/Python
-
-src_configure() {
- configuration() {
- # Fix out-of-source build and installation of .sip files
- ln -s "${S}"/sip || die
-
- local myconf=(
- "${PYTHON}"
- "${S}"/configure.py
- --pyqt=PyQt5
- --qmake="$(qt5_get_bindir)"/qmake
- --sip-incdir="$(python_get_includedir)"
- $(usex debug '--debug --trace' '')
- --verbose
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
-
- # Run eqmake to respect toolchain, build flags, and prevent stripping
- eqmake5 -recursive
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- emake INSTALL_ROOT="${D}" install
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-}