summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-28 09:13:49 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-28 10:03:35 +0100
commit0700ab45e7acb5d4d6116bb2e6847f566c5e48bf (patch)
treedf84c68ce078210956e96c4e459e869ca08893b8 /dev-python
parentdev-vcs/git: Stabilize 2.34.1 amd64, #830134 (diff)
downloadgentoo-0700ab45e7acb5d4d6116bb2e6847f566c5e48bf.tar.gz
gentoo-0700ab45e7acb5d4d6116bb2e6847f566c5e48bf.tar.bz2
gentoo-0700ab45e7acb5d4d6116bb2e6847f566c5e48bf.zip
dev-python/attrs: Bump to 21.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/attrs/Manifest1
-rw-r--r--dev-python/attrs/attrs-21.3.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/attrs/Manifest b/dev-python/attrs/Manifest
index c365823bb8e8..34e7f1b2225f 100644
--- a/dev-python/attrs/Manifest
+++ b/dev-python/attrs/Manifest
@@ -1 +1,2 @@
DIST attrs-21.2.0.tar.gz 184694 BLAKE2B 5c960f7c1a4623186c7a0cec8a9096df8df8e7d3022b67b281dcdd3a512ce6f105dfdd5ec10dc85a2b9971564f44e7b4474d760667e53cd2cf0f0543153eb6e2 SHA512 35863f599076357e40f72a62968f4a2f9bc2af9f59f484fef051be4f9730ce9e28e11568915d690ade7980df8998af22e2ff8b9568a205d7745e246ba5f3a7e1
+DIST attrs-21.3.0.tar.gz 204413 BLAKE2B 1aac1198196aa3438eb1ec9dac0a4971362caea655e27a2b7811e48d500a40fe8f2daf43ce86d3b381892763fdfecf9adbda16a29dda57155ec5a588732b423d SHA512 23b2ba52af809581e9907ad7c6d18ed050d415645a249ae912af3f1398276ea5bf67f11991d7958f3eeafe759d8d62a65009555ae8f75580cfa464c5b4a37742
diff --git a/dev-python/attrs/attrs-21.3.0.ebuild b/dev-python/attrs/attrs-21.3.0.ebuild
new file mode 100644
index 000000000000..6dff5827d645
--- /dev/null
+++ b/dev-python/attrs/attrs-21.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/python-attrs/attrs/
+ https://attrs.readthedocs.io/
+ https://pypi.org/project/attrs/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ $(python_gen_cond_dep '
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ ' 'python*')
+ >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=()
+ [[ ${EPYTHON} != python* ]] && EPYTEST_IGNORE+=(
+ # requires cloudpickle which relies on CPython implementation
+ # details
+ tests/test_3rd_party.py
+ )
+
+ epytest
+}