summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-07-28 07:06:42 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-07-28 07:06:42 +0700
commit0714332d34cc49f3ce29603825857fabc1391e6e (patch)
treee3274308b22f78f1142c339c9dad0c8c82de7743 /dev-python
parentx11-misc/light-locker: bump to 1.8.0 (diff)
downloadgentoo-0714332d34cc49f3ce29603825857fabc1391e6e.tar.gz
gentoo-0714332d34cc49f3ce29603825857fabc1391e6e.tar.bz2
gentoo-0714332d34cc49f3ce29603825857fabc1391e6e.zip
dev-python/sympy: bump to 1.1.1, an important patch re-added
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sympy/Manifest1
-rw-r--r--dev-python/sympy/files/sympy-1.1.1-zeta.patch29
-rw-r--r--dev-python/sympy/sympy-1.1.1.ebuild90
3 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index 6290308fadda..718207f73709 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,3 +1,4 @@
DIST sympy-0.7.6.1.tar.gz 6431571 SHA256 1fc272b51091aabe7d07f1bf9f0a47f3e28657fb2bec52bf3ef0e8f159f5f564 SHA512 18877abd3c530418e4f4942cbb0a03140dc81e5a1004720c472fb97cf8eaa41acca59765f6278715ea88bcd0cd07ad5952863a0d1b6e6d00994d257e8c0a6574 WHIRLPOOL b0c0c74e7865c91585d1a2c8510fe328b8e697dec02bd17aaa446ef6e089b9cf2ca5b4f58b6b59febccf142384b907e1bd47451e22fa305843bd883355801226
DIST sympy-1.0.tar.gz 4281528 SHA256 3eacd210d839e4db911d216a9258a3ac6f936992f66db211e22767983297ffae SHA512 977db6e9bc6a5918cceb255981a57e85e7060c0922aefd2968b004d25d704e25a5cb5bbe09eb387e8695581e23e2825d9c40310068fe25ece7e9c23037a21f39 WHIRLPOOL df02cc8603c23f621226f28b4f0555e765f145d968869058ed9420fedd3c6d6d0f095ee14fa864cd505455f245e5adf10794fc3b1392fb5a331ed5dc506b988b
+DIST sympy-1.1.1.tar.gz 4580952 SHA256 ac5b57691bc43919dcc21167660a57cc51797c28a4301a6144eff07b751216a4 SHA512 ff8857fd5810795554ca4f636b2d8e633057d7ea7df76461003d823ecbaddc98cde0561eb79a1058741c5ece233c13bfcb5e30d5bfb8ac6dbab3d05d8226f92b WHIRLPOOL 3ab86021e99de620127bbd3da994745d265e66fbe7ebf77984106f998443200dd7a5a3295cc62e3bca7e3eb1df58b331d1faba568760230fab550c5c2c3f92b9
DIST sympy-1.1.tar.gz 4579454 SHA256 e42d7b8cc719bb0427b503d49f8489ec6292c74957c3bd04216a8392bee37782 SHA512 4129752778b50fbc08180fe413d2109ad418b54b79caea461b9a6cf6856ab4f50ce95df6131b07791ed633c840648aa7c4dd130ab3f1cbb1e03e7346e995747b WHIRLPOOL bcee355015504a464c89f1cc2c35b3085af6d53a4d8c2245eda124ddbf53fb562b6a768b2d6cd79688b1255a21540094bd18e3f814dd729541a85767e27adb3c
diff --git a/dev-python/sympy/files/sympy-1.1.1-zeta.patch b/dev-python/sympy/files/sympy-1.1.1-zeta.patch
new file mode 100644
index 000000000000..d9bab8096fac
--- /dev/null
+++ b/dev-python/sympy/files/sympy-1.1.1-zeta.patch
@@ -0,0 +1,29 @@
+diff -U2 -r sympy-1.1.1.orig/sympy/functions/special/zeta_functions.py sympy-1.1.1/sympy/functions/special/zeta_functions.py
+--- sympy-1.1.1.orig/sympy/functions/special/zeta_functions.py 2017-07-22 05:17:42.000000000 +0700
++++ sympy-1.1.1/sympy/functions/special/zeta_functions.py 2017-07-28 06:35:28.477927184 +0700
+@@ -272,4 +272,5 @@
+ @classmethod
+ def eval(cls, s, z):
++ from sympy import unpolarify
+ if z == 1:
+ return zeta(s)
+@@ -277,5 +278,11 @@
+ return -dirichlet_eta(s)
+ elif z == 0:
+- return 0
++ return S.Zero
++
++ # branch handling
++ if (1 - abs(z)).is_nonnegative:
++ newz = unpolarify(z)
++ if newz != z:
++ return cls(s, newz)
+
+ def fdiff(self, argindex=1):
+@@ -483,5 +490,5 @@
+ For `\operatorname{Re}(s) > 0`, this function is defined as
+
+- .. math:: \eta(s) = \sum_{n=1}^\infty \frac{(-1)^n}{n^s}.
++ .. math:: \eta(s) = \sum_{n=1}^\infty \frac{(-1)^{n-1}}{n^s}.
+
+ It admits a unique analytic continuation to all of :math:`\mathbb{C}`.
diff --git a/dev-python/sympy/sympy-1.1.1.ebuild b/dev-python/sympy/sympy-1.1.1.ebuild
new file mode 100644
index 000000000000..35ea4c1cc066
--- /dev/null
+++ b/dev-python/sympy/sympy-1.1.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 eutils virtualx
+
+DESCRIPTION="Computer Algebra System in pure Python"
+HOMEPAGE="http://sympy.org"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples gtk imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+ latex? (
+ virtual/latex-base
+ dev-texlive/texlive-fontsextra
+ png? ( app-text/dvipng )
+ pdf? ( app-text/ghostscript-gpl )
+ )
+ mathml? (
+ dev-libs/libxml2:2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-libs/libxslt[${PYTHON_USEDEP}]' python2_7)
+ gtk? ( x11-libs/gtkmathview[gtk] )
+ )
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+ pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
+ symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
+ texmacs? ( app-office/texmacs )
+ theano? ( dev-python/theano[${PYTHON_USEDEP}] )
+"
+
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] app-text/docbook2X )
+ test? ( ${RDEPEND} dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-zeta.patch
+ "${FILESDIR}"/${PN}-1.0-doc-makefile.patch
+)
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
+python_compile_all() {
+ if use doc; then
+ export XDG_CONFIG_HOME="${T}/config-dir"
+ mkdir "${XDG_CONFIG_HOME}" || die
+ chmod 0700 "${XDG_CONFIG_HOME}" || die
+ emake -j1 -C doc html info man cheatsheet
+ fi
+}
+
+python_test() {
+ virtx "${PYTHON}" setup.py test
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.rst )
+ if use doc; then
+ DOCS+=( doc/_build/cheatsheet/cheatsheet.pdf \
+ doc/_build/cheatsheet/combinatoric_cheatsheet.pdf )
+ local HTML_DOCS=( doc/_build/html/. )
+ doinfo doc/_build/texinfo/${PN}.info
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+
+ if use texmacs; then
+ exeinto /usr/libexec/TeXmacs/bin/
+ doexe data/TeXmacs/bin/tm_sympy
+ insinto /usr/share/TeXmacs/plugins/sympy/
+ doins -r data/TeXmacs/progs
+ fi
+}