summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-28 09:29:59 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-28 10:03:42 +0100
commit0958164e77db17d7af5ce529535a94eee5520a7e (patch)
tree66218ca2cefbc232768fb3aa833643c1aeddb25e /dev-python
parentdev-python/flit: Bump to 3.6.0 (diff)
downloadgentoo-0958164e77db17d7af5ce529535a94eee5520a7e.tar.gz
gentoo-0958164e77db17d7af5ce529535a94eee5520a7e.tar.bz2
gentoo-0958164e77db17d7af5ce529535a94eee5520a7e.zip
dev-python/fritzconnection: Bump to 1.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fritzconnection/Manifest1
-rw-r--r--dev-python/fritzconnection/fritzconnection-1.8.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/fritzconnection/Manifest b/dev-python/fritzconnection/Manifest
index 0e259c98a13c..611df23e43bc 100644
--- a/dev-python/fritzconnection/Manifest
+++ b/dev-python/fritzconnection/Manifest
@@ -1,2 +1,3 @@
DIST fritzconnection-1.7.1.tar.gz 77805 BLAKE2B 4012975205320cc1c65ace64f515e1a934da5e330e9f9090021f20989d300df38f042cc8defd794ab6d4f2935cc2973141b50b1aea74a472d42f2dd5c1b2da57 SHA512 f3ca91b41a6255a743a00d34733e4755f1f675c150414c794bce9c52da292cc267a60520d5bc4e6b0e5ba4dc1ce27b7083fa4e2c226bafa3ca39ee6d63c80ae2
DIST fritzconnection-1.7.2.tar.gz 77880 BLAKE2B bb27d1cc8ccdce17a73ddc6a1f3fcb1187976dcaca28f773a6aad9c07f3dfa80be686d065d060fbf174b60b31bc589f26e6f48ae655a69b4a7ad2864d434156b SHA512 2ab6b010750e7dc7dd010fc51c3fa41ab2eee58c5f310f187e998183950a2ed2668a13a4a4a39bdb27fb1b0a8f69cfff47256ebd3b543128710368689551dc87
+DIST fritzconnection-1.8.0.tar.gz 77615 BLAKE2B aedcc3b116b6ce7ce14feb75714ee6e5a5ea667f7cb5e3124caa61e9b638e91e95a2520184869d088ceee7a6fd242c649660e7bb9ca81920f22954fc01ae3682 SHA512 4a65e715151fcd356ece60b9966560d80e4144d53f0684774af8f669fb83aa87124870ec1dfb29cbd381c73a711797f837b09abb620dfbb94722cba007fdf80c
diff --git a/dev-python/fritzconnection/fritzconnection-1.8.0.ebuild b/dev-python/fritzconnection/fritzconnection-1.8.0.ebuild
new file mode 100644
index 000000000000..00eeb7787fd3
--- /dev/null
+++ b/dev-python/fritzconnection/fritzconnection-1.8.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Lib/tool to communicate with AVM FRITZ! devices using TR-064 protocol over UPnP"
+HOMEPAGE="https://github.com/kbr/fritzconnection"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/kbr/fritzconnection"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/kbr/fritzconnection/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND=">=dev-python/requests-2.22[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest