summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-04 15:59:16 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-04 16:22:49 +0200
commit0ad67cd3112e91636bc91b4aeea3033b92437872 (patch)
tree81b4fc73a30241c4d2c30d8dc002c8d7dcad752a /dev-python
parentdev-python/docutils: Bump to 0.17 (diff)
downloadgentoo-0ad67cd3112e91636bc91b4aeea3033b92437872.tar.gz
gentoo-0ad67cd3112e91636bc91b4aeea3033b92437872.tar.bz2
gentoo-0ad67cd3112e91636bc91b4aeea3033b92437872.zip
dev-python/rich: Bump to 10.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-10.1.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 6a5eeff9168c..0a186f23c9d1 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,5 +1,6 @@
DIST rich-10.0.0.tar.gz 16217911 BLAKE2B 2604bf6a3bd57a9465fc2a001b497ff7f0afe83953d42fa8e5d9c0edfeadb0992503e2cf91cea30f177a641ebb3bb94d669945b601c88e5e796a107a08792e2f SHA512 5641df7d9ef1c1336077e357fb35c158b643afecfc3f2eb5023aa47042714d7c9fbbce7e52d0bce7c3b2c04b19e11985ca95807458dcf381fb2053becaf6ba1d
DIST rich-10.0.1.tar.gz 16218107 BLAKE2B 3992282b72ea97a364df3ca67e10a90baadb36ff207f64edee7e11df957b078d4b2c67bf3485efb7dddd0b3e8c2d3ae87e1d9b4d063db91f30c1a9510f7da976 SHA512 14689486b8a647c17fe6cad0902f4ecbf2c09e95ad0d4ea33b88bd9f8a17164f9efed4baa09a4ad6e6a85a9ec9fdeeccacd58eaa628efccb48fef6112487926c
+DIST rich-10.1.0.tar.gz 16218332 BLAKE2B 880fe5354b41a8a2accf7dc0d2f80163b850a28d3f4bd10b9f06008f3059c6a46681b3a344289c031589eeaa6120c5cad4a03d2c25f7a440829ff21e3fe20d63 SHA512 53cf49df20887b1788edc32bb98706c9bb5facee29aac4cbde9180aba4d97433eab49a144ba9b83393e36072b5e010630b3c7d67f80e280e380559698f6254d4
DIST rich-9.11.1.tar.gz 14050070 BLAKE2B 7dcae32743bfcbbab0af6896f72e865d2a72ab66545168544d065145cf10a2aab4785454e547f011219a85a8aa762f1ed5ebef2b9fb7f44225a2f776835b643d SHA512 2139cb6602d930e9bf1479456a8e6cee812237fb64073db3f23fd8eab64c1c2b3a83c6292f1f90652791100a93961d8ec8036e5d819f1e23159b6b9a75cd1f6c
DIST rich-9.12.4.tar.gz 16204429 BLAKE2B b57d7dc7ad4463c85cbc43e0fd8afd9f0c5329cbe81eaac168895af3701091669e4b0b6fd0d2de2f5876405c5aae00ed77e77d1b317dbd20c7dd3e53deddf2ca SHA512 92feb4ceab4e10f33c0f4abec19a4ee5bdcf27139591b603aba98239483874089fbd33998a2f05f2b609799afa59cddbe1ee245a87c391d15f58887b21a138df
DIST rich-9.13.0.tar.gz 16206916 BLAKE2B 27a058821f5bcdeaadf4ec9beadd0f2bb5357993a1c15cd72c6cac4def9c7c9d9d7705064853931bb868b7bf873a85469feb8a9c67daf88cdab8169f0d342b0c SHA512 bb93339f985c88b86897a9b21769877cb68f4a6f61a74b9e4a2a96aad0556502e6c848c4f769ee53c57bf03f0cfdfab97e004aa9d6572158a37037afee61f0ad
diff --git a/dev-python/rich/rich-10.1.0.ebuild b/dev-python/rich/rich-10.1.0.ebuild
new file mode 100644
index 000000000000..a62e88778e09
--- /dev/null
+++ b/dev-python/rich/rich-10.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}