summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-09-18 19:23:24 -0700
committerZac Medico <zmedico@gentoo.org>2016-09-18 19:24:23 -0700
commit0bc7a83a0ae13eaf4ccf5622a3e9d6c11fc050ba (patch)
treeea8240f0c11a8a751369acf99f3c23bad771e178 /dev-python
parentdev-libs/dbus-glib: Version bump to 0.108 (diff)
downloadgentoo-0bc7a83a0ae13eaf4ccf5622a3e9d6c11fc050ba.tar.gz
gentoo-0bc7a83a0ae13eaf4ccf5622a3e9d6c11fc050ba.tar.bz2
gentoo-0bc7a83a0ae13eaf4ccf5622a3e9d6c11fc050ba.zip
dev-python/pytest-mock: add package
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-mock/Manifest1
-rw-r--r--dev-python/pytest-mock/metadata.xml11
-rw-r--r--dev-python/pytest-mock/pytest-mock-1.2.ebuild33
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
new file mode 100644
index 000000000000..42731d1e74e0
--- /dev/null
+++ b/dev-python/pytest-mock/Manifest
@@ -0,0 +1 @@
+DIST pytest-mock-1.2.zip 19461 SHA256 f78971ed376fcb265255d1e4bb313731b3a1be92d7f3ecb19ea7fedc4a56fd0f SHA512 9b87c72e9895a16d4829229a070ba2b8143be894dfbc804b1e882eb2cc5843d8da9db258b5a2b9f8ae6738d9d612dbf1bec16790c5f99c27d9f7554cb676f852 WHIRLPOOL 470832b4df4a9392b0cfcbba96b2a52379d7111af0236f5dbe4e22f4e303da248bf2f936b3b66ae0ff3a197f3c87b0419c54c115fe5c6543e255f11666d3031d
diff --git a/dev-python/pytest-mock/metadata.xml b/dev-python/pytest-mock/metadata.xml
new file mode 100644
index 000000000000..6c61486a96fd
--- /dev/null
+++ b/dev-python/pytest-mock/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">pytest-mock</remote-id>
+ <remote-id type="github">pytest-dev/pytest-mock</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pytest-mock/pytest-mock-1.2.ebuild b/dev-python/pytest-mock/pytest-mock-1.2.ebuild
new file mode 100644
index 000000000000..380fa5a06ddc
--- /dev/null
+++ b/dev-python/pytest-mock/pytest-mock-1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with py.test"
+HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ dev-python/mock[python_targets_python2_7]
+ )
+ python_targets_pypy? (
+ dev-python/mock[python_targets_pypy]
+ )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH} \
+ py.test test_pytest_mock.py || die
+}