summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2016-06-06 09:14:56 +0200
committerCédric Krier <cedk@gentoo.org>2016-06-06 09:16:47 +0200
commit0d68f251903ef9555fded9039a0fe8e58ae89b60 (patch)
tree6c53340dc39fb6a60e2256ef036dc5e0a99af5c8 /dev-python
parentmedia-sound/cantata: Remove 2.0.0 (diff)
downloadgentoo-0d68f251903ef9555fded9039a0fe8e58ae89b60.tar.gz
gentoo-0d68f251903ef9555fded9039a0fe8e58ae89b60.tar.bz2
gentoo-0d68f251903ef9555fded9039a0fe8e58ae89b60.zip
dev-python/python-stdnum: version bump to 1.3
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-stdnum/Manifest1
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/Manifest b/dev-python/python-stdnum/Manifest
index 440a5204af0c..0bf296b4dd6e 100644
--- a/dev-python/python-stdnum/Manifest
+++ b/dev-python/python-stdnum/Manifest
@@ -1,2 +1,3 @@
DIST python-stdnum-0.9.tar.gz 136636 SHA256 c25bbdc6d8fb9d82e4d4d3c72545cff56eb8dd4389162e4ee415c3c7218136e6 SHA512 c9870ad116c2c08b123b7b01cc229a1f9d3f3e15da3ba75bdf5da8bee2a854474f6ddd7464c2d662559fedf272ea13a3549ed79a4636ddc1d733a47ea11ae058 WHIRLPOOL 3e124851b81e9cf8212994a8720b1b4994883d8175198fa1a0ee907dc989e4f5edd28c6e0f71c1a2b0df3987499f05f25405bfaa969e93c47c17fda7c4dc59a1
DIST python-stdnum-1.1.tar.gz 205495 SHA256 66ee880bfd60cadeca667eba6f29803b6712eb554a2d19cfb8e1ea86ce42df35 SHA512 b066b5cd4b04b70b52850942489f28165a833d2e29fe16eeec9b93e395f19742eaf2edc3cdbb31972e8ffd7ad46b189a186c3ed93bd91ab90e829681f54cf1f4 WHIRLPOOL 79c908885b0d3f89a300511d04f3283fcbaec02938ce763a263f40e6febef62c607ee241cc664bdbfc98176505b58ac69820fea717455bef3f17f5e93dcae8a9
+DIST python-stdnum-1.3.tar.gz 274077 SHA256 3e33f1d3e15fb5fe68518ed8a41d0f3247703f3a8d53864005529441c5ddc9d9 SHA512 44244937839ce1ebd18712fc090654ce44a063218714e57caf4041705159fdd9153b308647458dc38aaf21e5cf0bbda173437fb4760f9415252e355d8146c934 WHIRLPOOL 981b6a72fd86c60113ed0d61cff57407441fe60a98ee7cc9935d5d9a125954d287735bd91c86edb9db83740554dc667d0a7d260900d84016f36dffe2db8daf3f
diff --git a/dev-python/python-stdnum/python-stdnum-1.3.ebuild b/dev-python/python-stdnum/python-stdnum-1.3.ebuild
new file mode 100644
index 000000000000..1ce3022a320c
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="http://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies test"
+
+RDEPEND="vies? ( dev-python/suds )"
+DEPEND="${DEPEND}
+ dev-python/setuptools
+ test? ( dev-python/nose )"
+
+DOCS=( ChangeLog NEWS README )
+
+python_test() {
+ nosetests || die
+}