summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-09 08:48:02 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-09 09:15:51 +0200
commit1100d4c064a806b003daf45120abd948b98006d3 (patch)
treee47a67214e9d7018642115a87994dffef7a13d90 /dev-python
parentwww-client/chromium: dev channel bump to 87.0.4280.11 (diff)
downloadgentoo-1100d4c064a806b003daf45120abd948b98006d3.tar.gz
gentoo-1100d4c064a806b003daf45120abd948b98006d3.tar.bz2
gentoo-1100d4c064a806b003daf45120abd948b98006d3.zip
dev-python/testfixtures: Bump to 6.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/testfixtures/Manifest1
-rw-r--r--dev-python/testfixtures/testfixtures-6.15.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index f2974f18eee7..80e450e0f077 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1,2 +1,3 @@
DIST testfixtures-6.14.1.tar.gz 114969 BLAKE2B 21e6b377e24240cb275feed2e160da256ca75884c5a6dc842364986031c3cd21fb1b5bc13f3e8780354d47179e6c038cb461a39a04d34bfc8beebbf9809d6431 SHA512 0da31d5e382984c22ada846c07570d4a179ba819005dd29891e551b99190fabaaf17174456f7ed4864e9c4aa25f7d5d8b86aa123b4628328610d6930c9c5d6bd
DIST testfixtures-6.14.2.tar.gz 115229 BLAKE2B 311ef13cc6f596aa9d4c54c0cc02e25c412704eefa3474c3a078f4f50ba556e9872d3ecff3d122443986f0917b2e1c6fff8315d20bd319dec1148fd9851321ba SHA512 fbaeefc439a755d9f9e5ee223c6ce00288adfc2d12c9bef70ab06ea7bc4e9757d7a2429ac8046f7171aca1ac7d667f8a26168cd711f1cc4c719d66bbe8210cc6
+DIST testfixtures-6.15.0.tar.gz 116119 BLAKE2B cc0e351bd6778393cf061b741d7d593f56bc1b6a3d53d2e34baa006f7edd718c86f1b16c094e42cf116805a5c6652ac6827f71c1ebbb160d48c071317603c151 SHA512 34b9f1b9a5e76c5e20acf9abae2961694817de3822361cd5afc4a405ccdbcf26c617a01fbd8d2d977c2a0bc696232c2363df4a9fb7ba9187e0743cf2a6fe98e1
diff --git a/dev-python/testfixtures/testfixtures-6.15.0.ebuild b/dev-python/testfixtures/testfixtures-6.15.0.ebuild
new file mode 100644
index 000000000000..9d7fc72c7ede
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-6.15.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/sybil[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # kill weird way of declaring build deps
+ sed -e '/build=/d' -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH="." \
+ DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings \
+ pytest -vv || die
+}