summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 12:16:25 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 12:24:07 +0200
commit177b7b46f24e03cd4183c54160774c1f88522fe0 (patch)
treec1baf4e22b8a74c9c5f28811d1d68f43f020cad2 /dev-python
parentdev-python/requests: Remove python2 (diff)
downloadgentoo-177b7b46f24e03cd4183c54160774c1f88522fe0.tar.gz
gentoo-177b7b46f24e03cd4183c54160774c1f88522fe0.tar.bz2
gentoo-177b7b46f24e03cd4183c54160774c1f88522fe0.zip
dev-python/click: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/click/click-6.7-r2.ebuild (renamed from dev-python/click/click-6.7-r1.ebuild)24
-rw-r--r--dev-python/click/click-7.1.2-r1.ebuild (renamed from dev-python/click/click-7.1.2.ebuild)2
2 files changed, 4 insertions, 22 deletions
diff --git a/dev-python/click/click-6.7-r1.ebuild b/dev-python/click/click-6.7-r2.ebuild
index 4da283791c9f..d74a3ed19c0f 100644
--- a/dev-python/click/click-6.7-r1.ebuild
+++ b/dev-python/click/click-6.7-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
+PYTHON_COMPAT=( python3_{6,7} pypy3 )
inherit distutils-r1
@@ -14,15 +14,12 @@ HOMEPAGE="https://palletsprojects.com/p/click/ https://pypi.org/project/click/"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
-IUSE="doc examples test"
+IUSE="examples test"
RESTRICT="!test? ( test )"
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
PATCHES=(
# From upstream, can be removed in next release.
@@ -31,26 +28,11 @@ PATCHES=(
"${FILESDIR}/${PN}-6.7-support-sphinx-1.7.patch"
)
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
python_test() {
emake test
}
python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
use examples && dodoc -r examples
distutils-r1_python_install_all
}
diff --git a/dev-python/click/click-7.1.2.ebuild b/dev-python/click/click-7.1.2-r1.ebuild
index 803bc15a989c..9b40761fda04 100644
--- a/dev-python/click/click-7.1.2.ebuild
+++ b/dev-python/click/click-7.1.2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
inherit distutils-r1