summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 00:16:33 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:05:01 -0500
commit186e50a8f87da9daf7c860d1ca33ff7111506cce (patch)
tree243a9a9e3a28fda3f52fe533a9a10a72b171d840 /dev-python
parentdev-python/python-editor: 1.0.3 add py37 support (diff)
downloadgentoo-186e50a8f87da9daf7c860d1ca33ff7111506cce.tar.gz
gentoo-186e50a8f87da9daf7c860d1ca33ff7111506cce.tar.bz2
gentoo-186e50a8f87da9daf7c860d1ca33ff7111506cce.zip
dev-python/alembic: 1.0.8 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-1.0.8.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index 85015e21d8b3..cf3cd91a3c17 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1,3 +1,4 @@
DIST alembic-0.9.3.tar.gz 991744 BLAKE2B 2d18836fee1bd9a57cdc1b8f6159b9c1dc79b82a1bccd8cb62a597dfe47751992929630b9460e430be38bfd43d48cd1981858fa6b924a7283a48c12226867ef5 SHA512 1f39521a1cc9e1e8f8d344f2e48e1f656aed2ffda8e0608b9c5a9a7a1f0e4d16865ae0fba903023512a198afc70e72c683b0ff2bd1bc2e9ba6667009e940a63e
DIST alembic-0.9.5.tar.gz 990808 BLAKE2B a8155d15a9de2acb7a2f01829a0d01eeae5a7981a72aaa95e0d9d53433f52d0695d7e5414dbded1e5d53253a5e2d1cef67b12ed6be58d901859f3eae137486c1 SHA512 7588a681a6cf50a58ad697cb879d465d259880a473647d598242609c6321a8be7f53fc0d9a24fe976c4c65750eb0acc1a8e60253d4ccda33c87319ac9985e8b8
DIST alembic-0.9.7.tar.gz 1003312 BLAKE2B 2c8c2c14bede5f1997f8822ae6400718fa8302cef55020ef84975965295ccfa20885d48274a24e0c5dab72ec1611884d29d4bec422da8a93241aa280cda47dc3 SHA512 102592f7a25033af197fadc260dbb5ee4ad7038feb015fe5672de83c42f6125b659873071b339cccf5eebcf390c16651f6b9064f225198f88b42d58796fb1ca3
+DIST alembic-1.0.8.tar.gz 1030713 BLAKE2B 67cb80ed064e99f27e41a7ae2e42231794c177f96b95e2c3409a0ebc26e5323665147b2721efcc4a4d8ee2a71ada76408187f39ff5ad3745de64ed31f87d2895 SHA512 7a2ab63c6a823a32f45cd8ff5b763671806a8fa3d2b31e09c2051bdf92784fdafea1e3be217d84885d92eaf550e223ef77fd6fd387d35a5882d60ebcf042d835
diff --git a/dev-python/alembic/alembic-1.0.8.ebuild b/dev-python/alembic/alembic-1.0.8.ebuild
new file mode 100644
index 000000000000..4fb0c984646e
--- /dev/null
+++ b/dev-python/alembic/alembic-1.0.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://bitbucket.org/zzzeek/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test doc"
+
+# requires.txt cites 'SQLAlchemy>=0.7.3' which is really both old and silly
+# because it shatters the testsuite. If 'someone' cares to adhere to correct form
+# and edit to -0.7.3, feel free, and then pick up the pieces.
+RDEPEND=">=dev-python/sqlalchemy-0.9.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+# For test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # suite passes all if run from source. The residual fail & error are quite erroneous
+ rm tests/test_script_consumption.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${EPYTHON} run_tests.py || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}