summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-29 07:39:55 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-29 07:44:43 +0100
commit19b5202739246a87f3ecf9e69df22f652df18c34 (patch)
tree2dbd3870f490342530cc2595f5113c0a3508ed6c /dev-python
parentdev-python/pyfakefs: Bump to 3.7.1, py3.8 (diff)
downloadgentoo-19b5202739246a87f3ecf9e69df22f652df18c34.tar.gz
gentoo-19b5202739246a87f3ecf9e69df22f652df18c34.tar.bz2
gentoo-19b5202739246a87f3ecf9e69df22f652df18c34.zip
dev-python/pyfakefs: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyfakefs/Manifest2
-rw-r--r--dev-python/pyfakefs/files/pyfakefs-3.3-sandbox-tests.patch31
-rw-r--r--dev-python/pyfakefs/files/pyfakefs-3.4.1-tests.patch40
-rw-r--r--dev-python/pyfakefs/pyfakefs-3.3.ebuild26
-rw-r--r--dev-python/pyfakefs/pyfakefs-3.4.1.ebuild26
5 files changed, 0 insertions, 125 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index 2cfa22b3f977..ab3bbf8fcf9e 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1,5 +1,3 @@
-DIST pyfakefs-3.3.tar.gz 141704 BLAKE2B f805146024d9886ce6cb25b23f6f818bb37cac00a51528375b3da3e728515cb5ffd292352888861ff2b434ff71dd730bfbd84874fee0ae1f4d2cfca974f73771 SHA512 0044643964a4f2329d777476940b38d2d63c6de8f854992b4fba7b7e49f1186e7ce9811f83c9870655cbe33b7dda816c1aa1ce685e800e55c06d175c281748b7
-DIST pyfakefs-3.4.1.tar.gz 151662 BLAKE2B cbfdd7ab4c2936d484b5ff1e22852438c5c653e8875b7d363324e0a1aed0bfc5c492c2cd5c64a47052fcb4d043f567819f32067527b870ab42da8cfd92d40be3 SHA512 1be0254455f6046f1d28bf4377d17e0fb943b4b0db09e933c114f587f3d917877b23ee1610cf83a6330b406bb9ae66fe79dea31a6bf75c0b9c2b79a88d07e753
DIST pyfakefs-3.4.3.tar.gz 156896 BLAKE2B 2450cb67dbb25d2029a113dd95c3d51e60ef66c6683a5898ea73800ce1269d628af9f8daa85195d5b473f18b7c3262f2f26fc9c17caf80ce2f5159c247ebea5b SHA512 aafcad5d801f625273239221c56e46229ff8ab622cfb474d92f8555cfff90279ad9a092c20878279454c59033ad23d53cfe877023ac5d20c5a67a610b62ba7f1
DIST pyfakefs-3.5.8.tar.gz 171519 BLAKE2B 18eb784cf62108c3363b3b5fa137ec4ce830583d263dcecc6f007e6cdeb8a8eefcc4f9eecfba4a9b5b485508749f6dc75a47ff67bc8f5e77f2c0abae2cdd1778 SHA512 e72042dc80545d4a8602bf90bc832298184040389c8fd182df1ef33712061b4937623ca98d70e59b4a388677626f861ff096de939b5caa372849ee10fc3dd8bb
DIST pyfakefs-3.7.1.tar.gz 179420 BLAKE2B 46f902527c2c69af1d7d5e296a25d5415b4fba68d4ed76d7bc138e4b2d53dbd4bf7dc6fd75a8e5277eccb9740c67d5fdf5b640fbc577f22690ee32db434c3676 SHA512 910cef89443546c9a5f600cbe06cbdc396ac82d15d852768c06c2f97e764b05ee9fe9bea7687404a9a962924bd33c45d9de2a04b448fe6350d8cc31c4e163dfc
diff --git a/dev-python/pyfakefs/files/pyfakefs-3.3-sandbox-tests.patch b/dev-python/pyfakefs/files/pyfakefs-3.3-sandbox-tests.patch
deleted file mode 100644
index 58f24fc89bb0..000000000000
--- a/dev-python/pyfakefs/files/pyfakefs-3.3-sandbox-tests.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Fix sandbox issues with non-existent file tests.
-
---- pyfakefs-3.3/fake_filesystem_test.py
-+++ pyfakefs-3.3/fake_filesystem_test.py
-@@ -1418,7 +1418,6 @@
- self.os.chdir(directory)
- self.assertRaisesOSError(dir_error, self.os.remove, dir_path)
- self.assertTrue(self.os.path.exists(dir_path))
-- self.assertRaisesOSError(errno.ENOENT, self.os.remove, '/plugh')
-
- def testRemoveDirLinux(self):
- self.checkLinuxOnly()
-@@ -2811,8 +2810,8 @@
- # trying to create a link from a non-existent file should fail
- self.skipIfSymlinkNotSupported()
- self.assertRaisesOSError(errno.ENOENT,
-- self.os.link, '/nonexistent_source',
-- '/link_dest')
-+ self.os.link, 'nonexistent_source',
-+ 'link_dest')
-
- def testLinkDelete(self):
- self.skipIfSymlinkNotSupported()
-@@ -3158,7 +3157,6 @@
- self.os.chdir(directory)
- self.assertRaisesOSError(dir_error, self.os.remove, dir_path)
- self.assertTrue(self.os.path.exists(dir_path))
-- self.assertRaisesOSError(errno.ENOENT, self.os.remove, '/Plugh')
-
- def testRemoveDirMacOs(self):
- self.checkMacOsOnly()
diff --git a/dev-python/pyfakefs/files/pyfakefs-3.4.1-tests.patch b/dev-python/pyfakefs/files/pyfakefs-3.4.1-tests.patch
deleted file mode 100644
index d893a3adcb7a..000000000000
--- a/dev-python/pyfakefs/files/pyfakefs-3.4.1-tests.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Drop checks that fail due to sandboxing and skip failing tell check.
-
---- pyfakefs-3.4.1/tests/fake_os_test.py
-+++ pyfakefs-3.4.1/tests/fake_os_test.py
-@@ -449,7 +449,6 @@
- self.os.chdir(directory)
- self.assert_raises_os_error(dir_error, self.os.remove, dir_path)
- self.assertTrue(self.os.path.exists(dir_path))
-- self.assert_raises_os_error(errno.ENOENT, self.os.remove, '/plugh')
-
- def test_remove_dir_linux(self):
- self.check_linux_only()
-@@ -963,6 +962,8 @@
- self.assertEqual(b'\0\0abcde', f.read())
-
- def test_append_mode_tell_linux_windows(self):
-+ # skipping real fs test - python2 on the actual filesystem is also 7
-+ self.skip_real_fs()
- self.check_linux_and_windows()
- tell_result = 5 if self.is_python2 else 7
- self.check_append_mode_tell_after_truncate(tell_result)
-@@ -1885,8 +1886,8 @@
- # trying to create a link from a non-existent file should fail
- self.skip_if_symlink_not_supported()
- self.assert_raises_os_error(errno.ENOENT,
-- self.os.link, '/nonexistent_source',
-- '/link_dest')
-+ self.os.link, 'nonexistent_source',
-+ 'link_dest')
-
- def test_link_delete(self):
- self.skip_if_symlink_not_supported()
-@@ -2233,7 +2234,6 @@
- self.os.chdir(directory)
- self.assert_raises_os_error(dir_error, self.os.remove, dir_path)
- self.assertTrue(self.os.path.exists(dir_path))
-- self.assert_raises_os_error(errno.ENOENT, self.os.remove, '/Plugh')
-
- def test_remove_dir_mac_os(self):
- self.check_macos_only()
diff --git a/dev-python/pyfakefs/pyfakefs-3.3.ebuild b/dev-python/pyfakefs/pyfakefs-3.3.ebuild
deleted file mode 100644
index 0305b6844914..000000000000
--- a/dev-python/pyfakefs/pyfakefs-3.3.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit distutils-r1
-
-DESCRIPTION="a fake file system that mocks the Python file system modules"
-HOMEPAGE="https://github.com/jmcgeheeiv/pyfakefs/ https://pypi.org/project/pyfakefs/"
-SRC_URI="https://github.com/jmcgeheeiv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-PATCHES=( "${FILESDIR}"/${P}-sandbox-tests.patch )
-
-python_test() {
- "${PYTHON}" all_tests.py || die "tests failed under ${EPYTHON}"
-}
diff --git a/dev-python/pyfakefs/pyfakefs-3.4.1.ebuild b/dev-python/pyfakefs/pyfakefs-3.4.1.ebuild
deleted file mode 100644
index c4d151cc93a6..000000000000
--- a/dev-python/pyfakefs/pyfakefs-3.4.1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit distutils-r1
-
-DESCRIPTION="a fake file system that mocks the Python file system modules"
-HOMEPAGE="https://github.com/jmcgeheeiv/pyfakefs/ https://pypi.org/project/pyfakefs/"
-SRC_URI="https://github.com/jmcgeheeiv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-PATCHES=( "${FILESDIR}"/${P}-tests.patch )
-
-python_test() {
- "${PYTHON}" tests/all_tests.py || die "tests failed under ${EPYTHON}"
-}