summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-22 18:24:42 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-22 18:29:15 +0100
commit1a8386e80340387722af8bb40ce3c412cff0259c (patch)
tree56e778612295e3d59addf6b30c06464b497c8f68 /dev-python
parentsys-cluster/kube-scheduler: Remove old (diff)
downloadgentoo-1a8386e80340387722af8bb40ce3c412cff0259c.tar.gz
gentoo-1a8386e80340387722af8bb40ce3c412cff0259c.tar.bz2
gentoo-1a8386e80340387722af8bb40ce3c412cff0259c.zip
dev-python/pyblake2: Backport -fno-tree-vectorize to stable version
Bug: https://bugs.gentoo.org/638428
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyblake2/pyblake2-0.9.3-r1.ebuild (renamed from dev-python/pyblake2/pyblake2-0.9.3.ebuild)5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/pyblake2/pyblake2-0.9.3.ebuild b/dev-python/pyblake2/pyblake2-0.9.3-r1.ebuild
index e72595ae78bb..9245471a8a72 100644
--- a/dev-python/pyblake2/pyblake2-0.9.3.ebuild
+++ b/dev-python/pyblake2/pyblake2-0.9.3-r1.ebuild
@@ -46,6 +46,11 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+python_configure_all() {
+ # reported to break stuff, https://bugs.gentoo.org/638428
+ append-flags -fno-tree-vectorize
+}
+
python_test() {
"${EPYTHON}" test/test.py || die "Tests fail with ${EPYTHON}"
}