summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-05-23 10:31:28 +0200
committerIan Delaney <idella4@gentoo.org>2016-05-24 11:06:32 +0800
commit1b501b7197caf2844084488cbecdf6b66df5fad4 (patch)
treecd74b91fd5c5bbcd32c0133bf10e11ebd9f4259a /dev-python
parentapp-text/linuxdoc-tools: fix LICENSE (diff)
downloadgentoo-1b501b7197caf2844084488cbecdf6b66df5fad4.tar.gz
gentoo-1b501b7197caf2844084488cbecdf6b66df5fad4.tar.bz2
gentoo-1b501b7197caf2844084488cbecdf6b66df5fad4.zip
dev-python/flask-bootstrap: bump to 3.3.6.0
Package-Manager: portage-2.3.0_rc1 Closes: https://github.com/gentoo/gentoo/pull/1523 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/flask-bootstrap/Manifest1
-rw-r--r--dev-python/flask-bootstrap/flask-bootstrap-3.3.6.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/flask-bootstrap/Manifest b/dev-python/flask-bootstrap/Manifest
index fd71a78e56ce..7d2f40de198c 100644
--- a/dev-python/flask-bootstrap/Manifest
+++ b/dev-python/flask-bootstrap/Manifest
@@ -1 +1,2 @@
DIST flask-bootstrap-3.3.5.7.tar.gz 485387 SHA256 f0cb530ff85a6756dd42a73f49783484eb06db2153a8ebb2ee2f2bf3152f2fa7 SHA512 2d8ed707ccd0dc028f7d765e1f213890186583b28b3879dae0df0282c5e068c91a285691355acf6742999a8bd96920a614098bf9f79ab67f3f40c1a17ac452a6 WHIRLPOOL 81d31625f2b9e35147c34a265405da561a9f91b9ccaf439588c01df68ec33e00c358bcecd78353e21ac1bc8dc6fbbc0b9aed534976b080efead4b0647a46ced5
+DIST flask-bootstrap-3.3.6.0.tar.gz 489779 SHA256 b7e215fbd570940a5a29fa08d41ee5958b616947f39f93cbd9d0ae3e5ed6d56a SHA512 4cf08a6fd75185fdf5c89783cf8610d74835bf9dc07bd83b36819147bd40cf0e10d20f563a5fc5b8e799e2b87f1e80ad896c76930ca1bc72f74a94818ac708c8 WHIRLPOOL 2963b38b7f076e5289e75ff439eb9facf3b025a548b907cd4a8166c833f164aa6b631a4ffbcad95b0d90c384bb0ccb95523f7c244334232a6d8ce6f43fb94266
diff --git a/dev-python/flask-bootstrap/flask-bootstrap-3.3.6.0.ebuild b/dev-python/flask-bootstrap/flask-bootstrap-3.3.6.0.ebuild
new file mode 100644
index 000000000000..5dc2327e3279
--- /dev/null
+++ b/dev-python/flask-bootstrap/flask-bootstrap-3.3.6.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="An extension that includes Bootstrap in your project, without boilerplate code"
+HOMEPAGE="https://pythonhosted.org/Flask-Bootstrap/"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/flask-bootstrap/pull/134
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/dominate[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/visitor[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flask-appconfig[${PYTHON_USEDEP}]
+ dev-python/flask-debug[${PYTHON_USEDEP}]
+ dev-python/flask-nav[${PYTHON_USEDEP}]
+ dev-python/flask-wtf[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i "s/, 'sphinx.ext.intersphinx'//" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Skip one test which requires network access
+ py.test -k "not test_versions_match" || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}