summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2016-01-23 08:00:53 +0100
committerJohann Schmitz <ercpe@gentoo.org>2016-01-23 08:01:18 +0100
commit1ddc07eed736e619ba51f3f226f1bdfba03fa234 (patch)
tree0b9729e863d3ce3b6c2dbce10c43b112cfddafe4 /dev-python
parentsys-apps/pkgcore: simplify docs build/install (diff)
downloadgentoo-1ddc07eed736e619ba51f3f226f1bdfba03fa234.tar.gz
gentoo-1ddc07eed736e619ba51f3f226f1bdfba03fa234.tar.bz2
gentoo-1ddc07eed736e619ba51f3f226f1bdfba03fa234.zip
dev-python/shortuuid: Version bump to 0.4.3; added support for test
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/shortuuid/Manifest1
-rw-r--r--dev-python/shortuuid/shortuuid-0.4.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/shortuuid/Manifest b/dev-python/shortuuid/Manifest
index e1e192058c41..427fb3cd78ab 100644
--- a/dev-python/shortuuid/Manifest
+++ b/dev-python/shortuuid/Manifest
@@ -1 +1,2 @@
DIST shortuuid-0.4.2.tar.gz 5367 SHA256 47fa452b53fcf15427e539efd9fee8e625a9aebeb81db9339df7aeede52c2b61 SHA512 c60122bffdf458fb6aaf8ff4883d15f121ce8e5c0b24b99609171cc7bb103a1dbbf876b39e84129b50cc6ebfc1310740ffe684f7dfd93c750d0ff55d483273a3 WHIRLPOOL 648a63a48ecc2b8609b6d83cff41314b90b78488d85cfa2eed4b363029905d0d0238e52dad4f014dc419a6e8ed72fe1cdfc48f02d6e363aaf0ef1ac5b387a7f9
+DIST shortuuid-0.4.3.tar.gz 6096 SHA256 4606dbb19124d98109c00e2cafae2df8117aec02115623e18fb2abe3f766d293 SHA512 409bcaaff421a392640e39a7d25d4eaa320826971dca9d13270b61f21c78f65c617c302b3f7db5d0a3400c8ed4380a3a8eda90d1e9ad13d0a3a7eca53440ea7e WHIRLPOOL 3b9494b9332ab6fb04bdc6ab50271bc192a6c93fdbddab9d58ebee5d4e33f9823db389b1318dddb9518eb10b57ff30e74328c5ad109684310a8aa22465cb2503
diff --git a/dev-python/shortuuid/shortuuid-0.4.3.ebuild b/dev-python/shortuuid/shortuuid-0.4.3.ebuild
new file mode 100644
index 000000000000..a746f39b1894
--- /dev/null
+++ b/dev-python/shortuuid/shortuuid-0.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A generator library for concise, unambiguous and URL-safe UUIDs"
+HOMEPAGE="https://pypi.python.org/pypi/shortuuid"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pep8[${PYTHON_USEDEP}] )"
+
+python_test() {
+ ${EPYTHON} ${PN}/tests.py || die "Tests failed with ${EPYTHON}"
+} \ No newline at end of file