summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-09 22:18:48 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-09 22:53:55 +0200
commit1f28cc9c843ecd0a3a41c8416e5c560f8b9e9af5 (patch)
tree636e9fa9dbca7ba43eb55ef59a9c51e015ee3a04 /dev-python
parentdev-python/jwcrypto: Bump to 0.9.1 (diff)
downloadgentoo-1f28cc9c843ecd0a3a41c8416e5c560f8b9e9af5.tar.gz
gentoo-1f28cc9c843ecd0a3a41c8416e5c560f8b9e9af5.tar.bz2
gentoo-1f28cc9c843ecd0a3a41c8416e5c560f8b9e9af5.zip
dev-python/xmlschema: Bump to 1.6.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-1.6.4.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index edb7572e0265..49716e5938ee 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1 +1,2 @@
DIST xmlschema-1.6.2.tar.gz 367141 BLAKE2B 32a1e4924765badc268d2d68458c4d6d0409c5f3b4e0109487cc538aec300817cf0649a43f77990e82b2c54252b2ab3e0593a503c217893661480f1632491f41 SHA512 5aaf022451fa069b2361af542d4d864995e8dae7d50f5e66a5d5567b4d8511bb46b5dcec68a780e89025ff02f5bbb6311c4fcd4fb17f6c24c0c02b00c6b4a341
+DIST xmlschema-1.6.4.tar.gz 369270 BLAKE2B f3b98f0b8b4446dfa67da778c6b63585a894f4dcc9fd7ea98637ccd54b26e63aebc7f3fbc00e13ce43730b88da0f773a491917d5eae9301b5d22f6efe620473b SHA512 7e13d20a6add1cc5b6d0f732e672be3eeeb2f107fd2031cd5c22d1059d24b7d818c534817ea115d0c5f011727175bdcae71a0b8d55f1d6bd263a7e38286c26fc
diff --git a/dev-python/xmlschema/xmlschema-1.6.4.ebuild b/dev-python/xmlschema/xmlschema-1.6.4.ebuild
new file mode 100644
index 000000000000..2d0e12ac9848
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.6.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/elementpath-2.2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}