summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHan Mertens <hanmertens@outlook.com>2020-11-09 21:17:36 +0100
committerPatrice Clement <monsieurp@gentoo.org>2020-11-11 22:26:40 +0100
commit1f569f59422f100a5bd34cae4b85b2b7d8270ecc (patch)
treee13412147c912d2d9b6ac84e4f24f0c7ce2b83ed /dev-python
parentdev-python/pipenv: bump version to 2020.11.4. (diff)
downloadgentoo-1f569f59422f100a5bd34cae4b85b2b7d8270ecc.tar.gz
gentoo-1f569f59422f100a5bd34cae4b85b2b7d8270ecc.tar.bz2
gentoo-1f569f59422f100a5bd34cae4b85b2b7d8270ecc.zip
dev-python/uncertainties: add dev-pytohn/future as dependency.
Closes: https://bugs.gentoo.org/732832 Signed-off-by: Han Mertens <hanmertens@outlook.com> Closes: https://github.com/gentoo/gentoo/pull/18204 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild (renamed from dev-python/uncertainties/uncertainties-3.1.4.ebuild)17
1 files changed, 7 insertions, 10 deletions
diff --git a/dev-python/uncertainties/uncertainties-3.1.4.ebuild b/dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild
index f1decac029b5..0aff696ff8dd 100644
--- a/dev-python/uncertainties/uncertainties-3.1.4.ebuild
+++ b/dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
@@ -16,20 +16,17 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc"
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
distutils_enable_tests nose
-ppython_compile_all() {
- if use doc; then
- PYTHONPATH="${BUILD_DIR}"/lib esetup.py build_sphinx
- fi
-}
-
python_compile_all() {
use doc && "${PYTHON}" setup.py build_sphinx
}