summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-21 08:14:00 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-21 09:53:58 +0300
commit22094920eaefb2a95a394160c19b810a05e87312 (patch)
tree0d10e6c02d063d5bab02112ff3a1021aa9f00504 /dev-python
parentdev-python/python-netlink: mark ALLARCHES (diff)
downloadgentoo-22094920eaefb2a95a394160c19b810a05e87312.tar.gz
gentoo-22094920eaefb2a95a394160c19b810a05e87312.tar.bz2
gentoo-22094920eaefb2a95a394160c19b810a05e87312.zip
dev-python/ratelimit: add 2.2.1, enable py3.{9,10}
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ratelimit/Manifest1
-rw-r--r--dev-python/ratelimit/ratelimit-2.2.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ratelimit/Manifest b/dev-python/ratelimit/Manifest
index 773574177c96..00b669237d37 100644
--- a/dev-python/ratelimit/Manifest
+++ b/dev-python/ratelimit/Manifest
@@ -1 +1,2 @@
DIST ratelimit-1.4.1.tar.gz 10700 BLAKE2B d2fc1b0695c6bdc7653862ca790e9f5ec87b25513a93ec058384f334b47d5080570e3511eb6680b934b345ef5562771a078fc4ced3ceed263a7aafd26af3bfdd SHA512 ab8a2cc95b852f91c614ba5a5a677d2b4b99d5f810ec8a11e69d97af58cef1f67457e1cf686a286073c85b39c2ebbeca0a459382e410c9e8eda12cecdda57f02
+DIST ratelimit-2.2.1.gh.tar.gz 12366 BLAKE2B 7c810bd111202ef6cd86a789627367665457eb2fd88f13d91b18c934210b72f8f4b0ca1ae0e26b502234c4bf3e74d1c6608260d51a022f9f733d10eb061de023 SHA512 a9a2347e9f9e152e5b1ffcf346cf750c5c52471aa2216b485d989edfc55686077990676a35e0125277313ad50a656a14ab72b7aac61b661e2fc4ec74611b5990
diff --git a/dev-python/ratelimit/ratelimit-2.2.1.ebuild b/dev-python/ratelimit/ratelimit-2.2.1.ebuild
new file mode 100644
index 000000000000..469d3b4e290f
--- /dev/null
+++ b/dev-python/ratelimit/ratelimit-2.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="An API rate limit decorator for Python"
+HOMEPAGE="https://github.com/tomasbasham/ratelimit"
+SRC_URI="
+ https://github.com/tomasbasham/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove --cov args injection
+ rm pytest.ini || die
+ distutils-r1_src_prepare
+}