summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-04 08:06:09 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-04 09:08:07 +0200
commit26369d6b6432102c54f52206cd7e42c208143a8f (patch)
treeae1825ffd103f0b3fcc250141abcfa71b8aaf8f7 /dev-python
parentdev-python/twython: x86 stable wrt bug #720650 (diff)
downloadgentoo-26369d6b6432102c54f52206cd7e42c208143a8f.tar.gz
gentoo-26369d6b6432102c54f52206cd7e42c208143a8f.tar.bz2
gentoo-26369d6b6432102c54f52206cd7e42c208143a8f.zip
dev-python/arrow: Bump to 0.15.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/arrow/Manifest1
-rw-r--r--dev-python/arrow/arrow-0.15.6.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/arrow/Manifest b/dev-python/arrow/Manifest
index cff3ce62a672..03c1fd597a02 100644
--- a/dev-python/arrow/Manifest
+++ b/dev-python/arrow/Manifest
@@ -1,2 +1,3 @@
DIST arrow-0.13.1.tar.gz 148509 BLAKE2B 7a47f8886cc2f50f6dda682daab37c599aad15c7e4a0c76b1324f9fe3a1b8168e3a2b29352bdc9c4daf0fa3b3843fa919d5256997c673bcb24ca033312242b60 SHA512 4933e02fe4ef7a632d55e5c6d2cbcefe6840467c809e0377be92f02d0dc10b5b2421cea2be7ddd5158236ec80f44848125253bfeef5a2ae635a3b9c5761fa105
DIST arrow-0.15.5.tar.gz 82264 BLAKE2B 2091e16921a5f9f944de3f25ce853b50973d970d982b880fafa75ee37f98110dde05bfd02bb8ce27518ed17600e5bcfb8602c353d7e3af249aa4bfc4b642356d SHA512 cb147a1f2976e6cedddbf2d2d0d5ce69a4a609d4c0c3d68f96b317fc2af334552cb0c1a94aa5bb38e6d74ca7e1beab1ae8a325920a15efd79c35835c92df2409
+DIST arrow-0.15.6.tar.gz 83160 BLAKE2B 1a79e91a3185b8866653646f1a553d141b0c20b4712ab809add0362c76f7f9086a259db9827423074387017c439664e5c8bd663b719eadf725a4de608f370cc2 SHA512 c56316f8c535c6f14ccaab32e2559b45309170fd47e8728cdd8c0e2af9398264f90fbdd0ece82d14e3f959d24b186fac3e8bb52cf7a64fe0dcd4c247650c73b5
diff --git a/dev-python/arrow/arrow-0.15.6.ebuild b/dev-python/arrow/arrow-0.15.6.ebuild
new file mode 100644
index 000000000000..ff7a011cb868
--- /dev/null
+++ b/dev-python/arrow/arrow-0.15.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Better dates and times for Python"
+HOMEPAGE="https://github.com/crsmithdev/arrow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' setup.cfg || die
+ distutils-r1_src_prepare
+}