summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-27 00:21:52 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-27 00:42:52 -0600
commit2a4c6e2774284dba99dcd77b1564d0cbe61191f7 (patch)
treedcf9c5bf72582908c2b626bd5b65c2e70559b181 /dev-python
parentdev-python/aodhclient: bup (diff)
downloadgentoo-2a4c6e2774284dba99dcd77b1564d0cbe61191f7.tar.gz
gentoo-2a4c6e2774284dba99dcd77b1564d0cbe61191f7.tar.bz2
gentoo-2a4c6e2774284dba99dcd77b1564d0cbe61191f7.zip
dev-python/python-heatclient: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-heatclient/Manifest1
-rw-r--r--dev-python/python-heatclient/python-heatclient-1.8.0.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/python-heatclient/Manifest b/dev-python/python-heatclient/Manifest
index 55b88c5b45ab..156b074dfeed 100644
--- a/dev-python/python-heatclient/Manifest
+++ b/dev-python/python-heatclient/Manifest
@@ -1,2 +1,3 @@
DIST python-heatclient-0.8.0.tar.gz 121399 SHA256 5cd1c855ee21f18bfffbc7269e40c417b953d0855aa3cc8b56d778b8612467d5 SHA512 c17d445e646c3fc2f10bb622ba2a38299182e0a7841e0dae0e7c4482bc4d8868569b2204c18dc98456507d6f5abbf64db0b8e06c21bacf360883b24bfb01efc1 WHIRLPOOL 9c0b41d01458bcb3b26be163fb1e9e557b37fafc26d9698df73cfe722f8e02b991f36731e42bb5de88f2c7c3c0d86ee7154e1da76c99755cf9b7dcea0d79718e
DIST python-heatclient-1.5.0.tar.gz 176692 SHA256 42c253671c98c92dbd379b471f498000739e711afc2831d32b258a59bc48ee12 SHA512 656daa6a9f515f2d3b1f7fb7f3b4f54b0fc4798156b399486a8e950526be97707784521b252bf4551eaee6469df9aaff62cb98c935c215e149a77347c74a6138 WHIRLPOOL c28bbc4bcfeb47ad9fa56ca1b75a6e5c36ffa437ae3bb7071279bc5f34c96051d9dc0ac6bd44913444c1e02ee2548096c27ad17f1f9b3b7c25d32f921856eb79
+DIST python-heatclient-1.8.0.tar.gz 164289 SHA256 3e270a6030c4976d641af3f89671a581fc308399a7bbaeb3d0bb50b15a865d95 SHA512 f6e180583f8f0ed9e5b6db9782de5bf4f1adbbe929e2091a50bce29617c62b9689790efb2909e2a25cbd0bc7aec97ef4de3fa31abd0f22fac98c571c12305443 WHIRLPOOL 3d4796af51abbecf3c78865594e3c45b9131d9445a6f5fd6bbebe3ca651409c1d5001bc7cbb2d6d9b9ed9011600f00935fcd4926a7b000f5d0791196eef8cb64
diff --git a/dev-python/python-heatclient/python-heatclient-1.8.0.ebuild b/dev-python/python-heatclient/python-heatclient-1.8.0.ebuild
new file mode 100644
index 000000000000..0c092dc0a730
--- /dev/null
+++ b/dev-python/python-heatclient/python-heatclient-1.8.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Orchestration API Client Library"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
+ !~dev-python/mox3-0.19.0[${PYTHON_USEDEP}]
+ >dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ )
+"
+
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/python-swiftclient-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init
+ testr run || die "testsuite failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}