summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-02 10:00:06 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-02 10:20:31 +0100
commit2a7bac2746d60871fd1cc6bb92c4713c80973743 (patch)
tree7493d09f5c2f9d18fa648ac8a8f2f5d512c32ae6 /dev-python
parentnet-analyzer/zabbix: bump to 4.0.27 (diff)
downloadgentoo-2a7bac2746d60871fd1cc6bb92c4713c80973743.tar.gz
gentoo-2a7bac2746d60871fd1cc6bb92c4713c80973743.tar.bz2
gentoo-2a7bac2746d60871fd1cc6bb92c4713c80973743.zip
dev-python/botocore: Bump to 1.19.28
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.28.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index dfca16c45205..facabfadeccd 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -7,4 +7,5 @@ DIST botocore-1.19.23.tar.gz 7090433 BLAKE2B c5b6801e169b7c0325b33b005be0e409644
DIST botocore-1.19.24.tar.gz 7111127 BLAKE2B 61f368b4e8dad8d3a03d2a73cef68f7971bbe3a2173c55689eeacc166a983c8986039f62222884176f05df13002e31868ca498664f46452362f289bd44d8df2c SHA512 42ca145f9e47b61715c816add725758dcf617c663dcd0beee29e66a28047d3bd7908ce10b7614afe9111a539e74f436286b876c107bc3591f5689619939a4551
DIST botocore-1.19.25.tar.gz 7125010 BLAKE2B 18c03d1e61beb5b92fa958cbd6ad10d6048b51fd6b244187cfd27be0b3a0132bc2cdd0598d933cfde62a5f9cf92d2ddd2a0b7e269ace6e3319a3e37af2037bc9 SHA512 0cc4b015957330fbc5654b33953943c845c955a8fabb7b33672d496d68fe0e8783b1ba3254695bcdb7fa4b3775464f5c09af04e09931e38ba95710a6f0aa8320
DIST botocore-1.19.26.tar.gz 7124956 BLAKE2B 6091c9536de9a3171a2327ca1d1531799fa28af48870e37de8251b42a947a7f26881ee787964cd95a070acdcb4f3b634a816ab74a519b72287e61ad11aadeaa0 SHA512 bfdf3ff4fce1463fd1cb6fc2f8a97782d68388668b6dc3ffd0a0a3fac3d0f6b7da645c0a0d2d9183096c44b8b99dc2a0a9e1a29a7bc4b7ff0cbbbc3fb066f191
+DIST botocore-1.19.28.tar.gz 7208608 BLAKE2B eab5731c530747421186c3e24cc0cb0f5b120b37e4a4d587a5ec0b118d138ff13fb9608bd028a3182aa353f188f56f0c2a05c918aafc8d79eaa87ba89d5b4265 SHA512 71de40c171b1aabdcad159b2e6817740e793a29eda99c6cdad28643bc444a26fbcd7594d927bfbe031c4e4c8b74826ba51efb37376f5a70d8a2591c524a2301a
DIST botocore-1.19.9.tar.gz 6972834 BLAKE2B 3407c056c7995cc1ccb1b5b4c5b3a6254e38672b52e7889a7a022520283416e4dfcabd05c8ca0ed78e4624c7a20c9f43bfde87a76d7a72660b4c95256e4f9ca4 SHA512 8433f22ae7652e524a82da8d2ccda48da9eef44788333898b7526335d57a7757b80754f0d5c6a2c84ec3bde2ec9fc7da5cf872cbda7286f620b4f4878fe9a583
diff --git a/dev-python/botocore/botocore-1.19.28.ebuild b/dev-python/botocore/botocore-1.19.28.ebuild
new file mode 100644
index 000000000000..ca40b64d111f
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.28.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}