summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-08 09:20:24 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-08 09:25:24 +0100
commit2bc75e96c026dc19e4e53421d4de30d74143fa12 (patch)
tree60bb67b307b2c0fc67221a49a243b5c775cf1a24 /dev-python
parentdev-python/rich: Bump to 10.13.0 (diff)
downloadgentoo-2bc75e96c026dc19e4e53421d4de30d74143fa12.tar.gz
gentoo-2bc75e96c026dc19e4e53421d4de30d74143fa12.tar.bz2
gentoo-2bc75e96c026dc19e4e53421d4de30d74143fa12.zip
dev-python/flask-wtf: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/flask-wtf/Manifest1
-rw-r--r--dev-python/flask-wtf/flask-wtf-1.0.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/flask-wtf/Manifest b/dev-python/flask-wtf/Manifest
index cee9bb290266..6ba915043437 100644
--- a/dev-python/flask-wtf/Manifest
+++ b/dev-python/flask-wtf/Manifest
@@ -1 +1,2 @@
DIST Flask-WTF-0.15.1.tar.gz 45540 BLAKE2B 95ed9efaa89b487f406811926a8b206d15ad9c065f99595a35ea2ca4f98ede671673204c4085de91afe1e1b91b611ceb0f43b9c68b46fdd0e38d9025ac666f70 SHA512 9741e2c2285a500866b160e8c906c38ca579fdae2235bcba2336c7125ba614a9f75167c82bfcb96a45e553170c5925cb1a530d0164ecc57dc76cf1b560c40855
+DIST Flask-WTF-1.0.0.tar.gz 45365 BLAKE2B 13568ed3cbf7666c2c04663ec66c788d3cd4aa4fc7abc32938dfa703e7f120784c9491dc0ffe77fc42485c943b25f166b6540fa0f3de1d77df8a015300e1e468 SHA512 4b47e3586e3fb34f2ef964fb2a84d25c8279d4ce98e2064655e5ecb5f8fd67e4637ffd81b171e4623e2cd943e5abbcb6f5980ea8a354c2745d65c64161c0fd60
diff --git a/dev-python/flask-wtf/flask-wtf-1.0.0.ebuild b/dev-python/flask-wtf/flask-wtf-1.0.0.ebuild
new file mode 100644
index 000000000000..7052049cc1e8
--- /dev/null
+++ b/dev-python/flask-wtf/flask-wtf-1.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="Flask-WTF"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple integration of Flask and WTForms"
+HOMEPAGE="https://pythonhosted.org/Flask-WTF/ https://pypi.org/project/Flask-WTF/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/Babel-1[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-babel[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tries to access things over the network
+ tests/test_recaptcha.py
+ # unpackaged Flask-Uploads
+ tests/test_file.py
+)