summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-28 18:12:00 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-28 18:12:00 +0100
commit2bdbe2dc5adc070371ea2dc5df37a9e7d9c003ae (patch)
tree270ab3a836471238f8c18f1e2592435e48a7476e /dev-python
parentdev-python/pyClamd: Remove redundant versions (diff)
downloadgentoo-2bdbe2dc5adc070371ea2dc5df37a9e7d9c003ae.tar.gz
gentoo-2bdbe2dc5adc070371ea2dc5df37a9e7d9c003ae.tar.bz2
gentoo-2bdbe2dc5adc070371ea2dc5df37a9e7d9c003ae.zip
dev-python/pycodestyle: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycodestyle/Manifest1
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.3.1.ebuild37
2 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/pycodestyle/Manifest b/dev-python/pycodestyle/Manifest
index a135ba3e635f..b0f8d25bc760 100644
--- a/dev-python/pycodestyle/Manifest
+++ b/dev-python/pycodestyle/Manifest
@@ -1,2 +1 @@
-DIST pycodestyle-2.3.1.tar.gz 89460 BLAKE2B 0b7e23be13830954277d521262e9504ade8a4d0275a77e6365201ccffae955a8f505a1cd5e739145e1fc5551c3b956ff9a51bb57cede819f2886ee36637f7f9e SHA512 276bc21b4e6898e379be88f3582135a21314460ad20d4b6c3e12825ac1a72082b2c08bb62099e704c3222f879a1098d0b305132fac1095aaa60ca239b9763a2d
DIST pycodestyle-2.5.0.tar.gz 98802 BLAKE2B ec86642f0f37abc4da8886df6395694b54cbe4e1d0030615b2136f0bc265825df254f019483e9094feaad685e43008cefdf0e50b533df434a40de0de11aa5fa1 SHA512 84e751a7d00048393b02ca743de5d71d1641e948ee1b4daebbdf2d07e0cd8f087ca4e81f826061114b40ef41920bbcd680c9f479e7cc1a159a70188425717208
diff --git a/dev-python/pycodestyle/pycodestyle-2.3.1.ebuild b/dev-python/pycodestyle/pycodestyle-2.3.1.ebuild
deleted file mode 100644
index d96e2d151da5..000000000000
--- a/dev-python/pycodestyle/pycodestyle-2.3.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python style guide checker (fka pep8)"
-HOMEPAGE="https://pypi.org/project/pycodestyle/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --statistics pycodestyle.py || die
- PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --testsuite=testsuite || die
- PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py --doctest -v || die
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}