summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-10-12 00:00:43 +0300
committerMart Raudsepp <leio@gentoo.org>2020-10-12 00:01:10 +0300
commit2df67ca296c95ad8496dd05413221d28ad3911af (patch)
treece683ecaa58f0eb691b20d9f760aece7e88545ef /dev-python
parentapp-text/ghostscript-gpl: drop old (diff)
downloadgentoo-2df67ca296c95ad8496dd05413221d28ad3911af.tar.gz
gentoo-2df67ca296c95ad8496dd05413221d28ad3911af.tar.bz2
gentoo-2df67ca296c95ad8496dd05413221d28ad3911af.zip
dev-python/pygobject: don't skip tests on disabled py2
It's py3-only now, so no need for the code from commit a07e2a8c90a4307ef9eccd6c7605568eb692a0f1 anymore. Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygobject/pygobject-3.36.1-r1.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/dev-python/pygobject/pygobject-3.36.1-r1.ebuild b/dev-python/pygobject/pygobject-3.36.1-r1.ebuild
index e07d82e9ea83..774991e0a087 100644
--- a/dev-python/pygobject/pygobject-3.36.1-r1.ebuild
+++ b/dev-python/pygobject/pygobject-3.36.1-r1.ebuild
@@ -27,13 +27,11 @@ RDEPEND="${PYTHON_DEPS}
"
DEPEND="${RDEPEND}
test? (
- $(python_gen_cond_dep '
- dev-libs/atk[introspection]
- dev-python/pytest[${PYTHON_USEDEP}]
- x11-libs/gdk-pixbuf:2[introspection,jpeg]
- x11-libs/gtk+:3[introspection]
- x11-libs/pango[introspection]
- ' -3)
+ dev-libs/atk[introspection]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf:2[introspection,jpeg]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
)
"
BDEPEND="
@@ -62,11 +60,6 @@ src_test() {
local -x GIO_USE_VOLUME_MONITOR="unix" # prevent udisks-related failures in chroots, bug #449484
testing() {
- if ! python_is_python3; then
- einfo "Skipping tests on Python 2 to unblock deps"
- return
- fi
-
local -x XDG_CACHE_HOME="${T}/${EPYTHON}"
meson_src_test || die "test failed for ${EPYTHON}"
}