summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSÅ‚awomir Lis <slis@gentoo.org>2015-11-05 13:35:04 +0100
committerSÅ‚awomir Lis <slis@gentoo.org>2015-11-05 13:36:44 +0100
commit2e4a42a9ab20f4e9657f497f2a18cff8f0db0064 (patch)
tree110846af048721c09e0db7db7e7000181fc8f502 /dev-python
parentadded djangocms-video (diff)
downloadgentoo-2e4a42a9ab20f4e9657f497f2a18cff8f0db0064.tar.gz
gentoo-2e4a42a9ab20f4e9657f497f2a18cff8f0db0064.tar.bz2
gentoo-2e4a42a9ab20f4e9657f497f2a18cff8f0db0064.zip
Added django-cms (#427738)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-cms/Manifest1
-rw-r--r--dev-python/django-cms/django-cms-3.1.2.ebuild42
-rw-r--r--dev-python/django-cms/metadata.xml39
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/django-cms/Manifest b/dev-python/django-cms/Manifest
new file mode 100644
index 000000000000..ed0855548d99
--- /dev/null
+++ b/dev-python/django-cms/Manifest
@@ -0,0 +1 @@
+DIST django-cms-3.1.2.tar.gz 4031123 SHA256 b59c89b6f7c3a802e74fe16159eb663df4b49fb676b6931d678fd5261a5fdb9b SHA512 ef8c2f25032f784b4f4a3d6b595577ee890fd249c54a71207eb6c2c7b3495164171db6f0e2f4aa49ed4b8e3ff5e682757ea2f396b69ff46d93419a35489fd213 WHIRLPOOL 85a22c9679b84fe04e4b29606328a50373a1d7aaa8174ee54e82d0cca08ef62ca8e3b946cf6ed0670f52253697046ecf65e2a8675ba9820286390b7af59dc143
diff --git a/dev-python/django-cms/django-cms-3.1.2.ebuild b/dev-python/django-cms/django-cms-3.1.2.ebuild
new file mode 100644
index 000000000000..04f3a7b91c62
--- /dev/null
+++ b/dev-python/django-cms/django-cms-3.1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_{6,7},3_{3,4}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django application for managing hierarchical pages of content"
+HOMEPAGE="https://www.django-cms.org/"
+SRC_URI="https://github.com/divio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="+admin-style +ckeditor file flash inherit link picture snippet teaser video"
+REQUIRED_USE="admin-style ckeditor"
+
+RDEPEND="
+ >=dev-python/django-1.6.9
+ admin-style? ( dev-python/djangocms-admin-style )
+ file? ( dev-python/djangocms-file )
+ flash? ( dev-python/djangocms-flash )
+ inherit? ( dev-python/djangocms-inherit )
+ link? ( dev-python/djangocms-link )
+ picture? ( dev-python/djangocms-picture )
+ snippet? ( dev-python/djangocms-snippet )
+ teaser? ( dev-python/djangocms-teaser )
+ video? ( dev-python/djangocms-video )
+ >=dev-python/django-classy-tags-0.5
+ >=dev-python/django-sekizai-0.7
+ ckeditor? ( >=dev-python/djangocms-text-ckeditor-2.1.1 )
+ dev-python/django-treebeard
+ dev-python/html5lib
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools
+"
diff --git a/dev-python/django-cms/metadata.xml b/dev-python/django-cms/metadata.xml
new file mode 100644
index 000000000000..241664d35fa8
--- /dev/null
+++ b/dev-python/django-cms/metadata.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>slis@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="admin-style">
+ Install plugin customizing admin panel styles
+ </flag>
+ <flag name="ckeditor">
+ Install text-ckeditor plugin for rich text editing
+ </flag>
+ <flag name="file">
+ Install djangocms file plugin
+ </flag>
+ <flag name="flash">
+ Install djangocms flash plugin
+ </flag>
+ <flag name="inherit">
+ Install djangocms inherit plugin
+ </flag>
+ <flag name="link">
+ Install djangocms link plugin
+ </flag>
+ <flag name="picture">
+ Install djangocms picture plugin
+ </flag>
+ <flag name="snippet">
+ Install djangocms snippet plugin
+ </flag>
+ <flag name="teaser">
+ Install djangocms teaser plugin
+ </flag>
+ <flag name="video">
+ Install djangocms video plugin
+ </flag>
+ </use>
+</pkgmetadata> \ No newline at end of file