summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-10-10 10:45:00 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-10-10 10:48:53 -0500
commit2ea4a585fedf130c3faa5b3d9098258fa1069787 (patch)
tree84a8ea4e2f1db47e13129251cb828590e0664306 /dev-python
parentdev-python/dnspython: adding py37 support (diff)
downloadgentoo-2ea4a585fedf130c3faa5b3d9098258fa1069787.tar.gz
gentoo-2ea4a585fedf130c3faa5b3d9098258fa1069787.tar.bz2
gentoo-2ea4a585fedf130c3faa5b3d9098258fa1069787.zip
dev-python/monotonic: 1.5 bump with py37 support
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/monotonic/Manifest1
-rw-r--r--dev-python/monotonic/monotonic-1.5.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/monotonic/Manifest b/dev-python/monotonic/Manifest
index 11d19e1988ae..3634cb638c9f 100644
--- a/dev-python/monotonic/Manifest
+++ b/dev-python/monotonic/Manifest
@@ -1,2 +1,3 @@
DIST monotonic-1.3.tar.gz 7211 BLAKE2B ee05b43f8734099c3d7472ff98bc815cb33cd45d33cd780f33703429773cb3f7cccbf97c3e476247b749616f16ee4493cf300ea137b6da89068c912e4689f72c SHA512 870b9530235715eda099cc332c94935ebb80f52a30523dca90639b9f8b3391dd706a9a8f3aac402ebd8c008672e84cd09b5397e954160751e71940b3a9120bd9
DIST monotonic-1.4.tar.gz 7463 BLAKE2B c9123bb5ed5ece16014c9467c7e25dfaee8d0f30096a73f5d001b0bfc965c0c1f2b501ae39f5b490edd61f179c4e688ce4b794bdb6a842ba350d499eccd8335f SHA512 f9fa079cc325592b0bff799fabe7f9e87922cfe351776ed08be7a0060d27f81ae2c23aa7a1fac2ac2203ec26547e05fe3a918e68e6a474768b431ce860522eca
+DIST monotonic-1.5.tar.gz 7525 BLAKE2B e6022a9c134031f1b89e643b4f7b37417366e08de213f580a39706e7cd57b1045e8f1625be213c90fba48b69c40461d0c90255e6a9f20e565ea9a857780e2143 SHA512 05485e0baa51df95f9812d463306ce0bbe7228170b43aed8faa9d77d2b613ffede6b57b3dd273c352e0d1c04782043bec2f36be88cb1acde182a5aeb0538f970
diff --git a/dev-python/monotonic/monotonic-1.5.ebuild b/dev-python/monotonic/monotonic-1.5.ebuild
new file mode 100644
index 000000000000..72cfe7194bd6
--- /dev/null
+++ b/dev-python/monotonic/monotonic-1.5.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of time.monotonic() for Python 2 & < 3.3"
+HOMEPAGE="https://github.com/atdt/monotonic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""