summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-20 16:16:44 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-20 16:35:56 +0100
commit2eee6bfc4d39ccce9c4a199a77082195affa9f81 (patch)
tree8f0526dd7f13cfbeb20bf45ad4fad153f064fb1f /dev-python
parentdev-python/ipython: Version Bump (diff)
downloadgentoo-2eee6bfc4d39ccce9c4a199a77082195affa9f81.tar.gz
gentoo-2eee6bfc4d39ccce9c4a199a77082195affa9f81.tar.bz2
gentoo-2eee6bfc4d39ccce9c4a199a77082195affa9f81.zip
dev-python/CacheControl: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/CacheControl/CacheControl-0.11.6.ebuild37
-rw-r--r--dev-python/CacheControl/Manifest1
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/CacheControl/CacheControl-0.11.6.ebuild b/dev-python/CacheControl/CacheControl-0.11.6.ebuild
new file mode 100644
index 000000000000..f0ae57a4c600
--- /dev/null
+++ b/dev-python/CacheControl/CacheControl-0.11.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="The httplib2 caching algorithms packaged up for use with requests"
+HOMEPAGE="https://github.com/ionrock/cachecontrol https://pypi.python.org/pypi/cachecontrol/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/lockfile-0.9[${PYTHON_USEDEP}]"
+DEPENDS="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+# Not included
+RESTRICT=test
+
+python_test() {
+ py.test -v -v || die
+}
+
+pkg_postinst() {
+ optfeature "Redis based caches" dev-python/redis-py
+}
diff --git a/dev-python/CacheControl/Manifest b/dev-python/CacheControl/Manifest
index 8ff739c25976..45fad05b6cae 100644
--- a/dev-python/CacheControl/Manifest
+++ b/dev-python/CacheControl/Manifest
@@ -1 +1,2 @@
DIST CacheControl-0.11.5.tar.gz 13104 SHA256 b78484d6feb17b501267f4048c364a8fc26fcef35ca3ff62bdba63d41fa4cf42 SHA512 2acce5a8be2e409a1a18254cfe71314074037bce3341f8b8fdec52c43500c90bfdb6063b2121c5cf6c8a2fc7c0903e4fd0c15813ffdfa547810b33571d211deb WHIRLPOOL 5e12640ba5c952ee8a83f5271bbbd105f148cd080bf6ae5c2cbc9c6cc20361005aa5cf1a95feaa1a808c56c26b7abdfbde3b7bffc873f26072d23262c12b49ca
+DIST CacheControl-0.11.6.tar.gz 13642 SHA256 37dfcb453e7f186c95b330834a1673e022db900d5e3a883f80257c4369477695 SHA512 5640805db3a0f3e0e96192f2122159f0391be4821934ae6624b2778e91de319d5acf0e8693d00cf9910314ff7e2e1e7d2c82789b46fb012363fbb1c38dcb0d29 WHIRLPOOL 9187c18e12196b379136afa89d64c5dda461f9f0fa1764a5922046d579d9c10921a7bc8f8b409db29cd51d6bc0c358ab9bd8f3cf142de375da2b0a5723ed4117