summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2016-10-11 23:35:08 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-14 23:29:34 +0200
commit31303d6dfae7fddac74f2abb81cc208e728b1cce (patch)
treeeeb4a7febef7c4d67ba8dbfa9bbc6622e6c2be4a /dev-python
parentdev-python/lxml: revision bump 3.5.0-r1 (diff)
downloadgentoo-31303d6dfae7fddac74f2abb81cc208e728b1cce.tar.gz
gentoo-31303d6dfae7fddac74f2abb81cc208e728b1cce.tar.bz2
gentoo-31303d6dfae7fddac74f2abb81cc208e728b1cce.zip
dev-python/lxml: disable broken test-case, EAPI bump
There is a test-case not working because of issues in libxml2. The patch disables the one broken test-case until upstream can fix it. Upstream bug: https://bugs.launchpad.net/lxml/+bug/1608479 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=592860 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2539 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/lxml/lxml-3.5.0-r1.ebuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/dev-python/lxml/lxml-3.5.0-r1.ebuild b/dev-python/lxml/lxml-3.5.0-r1.ebuild
index f6cb9e23f9f3..bbaf02f89b6c 100644
--- a/dev-python/lxml/lxml-3.5.0-r1.ebuild
+++ b/dev-python/lxml/lxml-3.5.0-r1.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
inherit distutils-r1 eutils flag-o-matic toolchain-funcs
@@ -28,7 +28,15 @@ DEPEND="${RDEPEND}
DISTUTILS_IN_SOURCE_BUILD=1
-PATCHES=( "${FILESDIR}"/${P}-cross-compile.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-cross-compile.patch
+
+ # This patch removes a testcase that fails because of issues
+ # in libxml2.
+ #
+ # Upstream bug: https://bugs.launchpad.net/lxml/+bug/1608479
+ "${FILESDIR}"/${PN}-3.6.4-fix-test_xmlschema.patch
+)
python_prepare_all() {
# avoid replacing PYTHONPATH in tests.
@@ -39,7 +47,7 @@ python_prepare_all() {
python_compile() {
if [[ ${EPYTHON} != python3* ]]; then
- local CFLAGS=${CFLAGS}
+ local -x CFLAGS="${CFLAGS}"
append-cflags -fno-strict-aliasing
fi
tc-export PKG_CONFIG
@@ -51,7 +59,7 @@ python_test() {
cp -r -l src/lxml/html/tests "${BUILD_DIR}"/lib/lxml/html/ || die
ln -s "${S}"/doc "${BUILD_DIR}"/ || die
- "${PYTHON}" test.py -vv --all-levels -p || die "Test ${test} fails with ${EPYTHON}"
+ "${EPYTHON}" test.py -vv --all-levels -p || die "Test ${test} fails with ${EPYTHON}"
}
python_install_all() {
@@ -59,7 +67,10 @@ python_install_all() {
local DOCS=( *.txt doc/*.txt )
local HTML_DOCS=( doc/html/. )
fi
- use examples && local EXAMPLES=( samples/. )
+ if use examples; then
+ docinto examples
+ dodoc -r samples/.
+ fi
distutils-r1_python_install_all
}