summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-29 11:49:48 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-29 11:49:48 +0200
commit351190af49b1a1198e6364e26b8d852adf1c2862 (patch)
tree815b5e84c83b7a5e0a27774419c1bad82309ba27 /dev-python
parentdev-python/pyphen: Add py3.5 support (diff)
downloadgentoo-351190af49b1a1198e6364e26b8d852adf1c2862.tar.gz
gentoo-351190af49b1a1198e6364e26b8d852adf1c2862.tar.bz2
gentoo-351190af49b1a1198e6364e26b8d852adf1c2862.zip
dev-python/weasyprint: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-0.29.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index a7856a893a37..d302d6a5944a 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -2,3 +2,4 @@ DIST WeasyPrint-0.21.tar.gz 333898 SHA256 312af72805fd5207ccd58d1c59022bf1e9cf8e
DIST WeasyPrint-0.22.tar.gz 342786 SHA256 78874291649d8013b60462c39456fea8d1097e55bb45907f6c3e30ffe4822bf1 SHA512 f5b7189a9c5408d052cde995a9ff6aa2df04cbf97297c8f2c03d8f12aa84833f7a82b63eac700032570c289a8ce0dbab687d0127518b6743fd95dfb60cbf5993 WHIRLPOOL e2f6efc58a3344c655814b0fcb9b6541e8a3f8e8e4e82240ea34580517095d7622f434bd83da6071184270df6c94cc7771376b87743439a1c3e9a357d72520a6
DIST WeasyPrint-0.23.tar.gz 343614 SHA256 4c3539b8bf6145f6ae9de657eb4b008ccf29066d876f948ecbcfa753a5b0eae4 SHA512 bd9e4da6bd9ffc63e6acedbf821d2fa7b791f9d28c61e465effa0596665b5b76fec1a4bef2dd8f2c98ee768884ef84f842fc67664b41f84d4a0c22d86e032d71 WHIRLPOOL 1a9f0e0d442b7487ffa039c726f41fa80fdce06df4f3d2d931eda3974ce4b4da69dea929d018c9c95a9dc02ff0d5cf9158059bc7ce3293a4997fa2550d5f755f
DIST WeasyPrint-0.26.tar.gz 352596 SHA256 444bb7fe3d6864f7b17d01fef88340fb283504eb941fa0add883dd1f04635b71 SHA512 165ff0927cb644abd800fad1f31d2d302cf1a6e8cb2422a149ba41b0f8a6633e6f4d3a11f61c51be63dbb03244716327299feb45bd7737d44df29df5f2b8b0c8 WHIRLPOOL 2e3593c7aa051633010773ebeeefb3e1d6de9c0ae5c0974a01c46eef69aee5972fd3d36ada8b11f6cd968ce7af9224232d49541fe61d22036fb4dcf29f796a7f
+DIST WeasyPrint-0.29.tar.gz 1418105 SHA256 4edf5538b330be3e559f006db76a5a948c25f3792746aafb20f2a9d6185f0e71 SHA512 3875240b7bed6991372f6a45f82d32f0d2f3add29ab1937001c5559368405737d185aa85871358730989a91ee6b17e62cc21535735c884c47705d0d2d38bb167 WHIRLPOOL cbefe32d42e5bbc26993b58f88b2ebc26291579dd717805c8fc9c54d41fe69b3a05eb8f301e9c21b426766404c9a683cce6c115ed8193456d17c83b44c8513a9
diff --git a/dev-python/weasyprint/weasyprint-0.29.ebuild b/dev-python/weasyprint/weasyprint-0.29.ebuild
new file mode 100644
index 000000000000..bf9f36de9ff6
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-0.29.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+MY_PN="WeasyPrint"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://weasyprint.org https://github.com/Kozea/WeasyPrint"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Note: specific subslot of pango since it inlines some of pango headers.
+RDEPEND="x11-libs/pango:0/0
+ >=media-gfx/cairosvg-1.0.7[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-0.999[${PYTHON_USEDEP}]
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
+ >=dev-python/cairocffi-0.5[${PYTHON_USEDEP}]
+ ~dev-python/tinycss-0.3[${PYTHON_USEDEP}]
+ >=dev-python/cssselect-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.8[${PYTHON_USEDEP}]"
+# x11-libs/gdk-pixbuf # optional dep
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ media-fonts/ahem )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ py.test || die "testsuite failed under ${EPYTHON}"
+}