summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 16:28:01 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 16:30:21 +0200
commit3528be69a3432ab1baae658368107ab701661eb3 (patch)
tree3fc929c7deaf0476938453597c37f160cd7b6f2d /dev-python
parentdev-python/pytest-timeout: Remove python2 (diff)
downloadgentoo-3528be69a3432ab1baae658368107ab701661eb3.tar.gz
gentoo-3528be69a3432ab1baae658368107ab701661eb3.tar.bz2
gentoo-3528be69a3432ab1baae658368107ab701661eb3.zip
dev-python/hypothesis: Remove tests from <5 to unblock deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/hypothesis-4.57.1.ebuild18
1 files changed, 1 insertions, 17 deletions
diff --git a/dev-python/hypothesis/hypothesis-4.57.1.ebuild b/dev-python/hypothesis/hypothesis-4.57.1.ebuild
index 0a1109d059e1..c77bd835859f 100644
--- a/dev-python/hypothesis/hypothesis-4.57.1.ebuild
+++ b/dev-python/hypothesis/hypothesis-4.57.1.ebuild
@@ -16,23 +16,13 @@ SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar
LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
+RESTRICT="test"
RDEPEND="
>=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
>=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
- !!<dev-python/typing-3.7.4.1
- )
-"
S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
@@ -46,12 +36,6 @@ src_prepare() {
distutils-r1_src_prepare
}
-python_test() {
- local pyver=$(python_is_python3 && echo 3 || echo 2)
- pytest -vv tests/cover tests/pytest tests/py${pyver} ||
- die "Tests fail with ${EPYTHON}"
-}
-
pkg_postinst() {
optfeature "datetime support" dev-python/pytz
optfeature "dateutil support" dev-python/python-dateutil