summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-11 08:21:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-11 10:50:14 +0200
commit3579b6b3c6978d0ed290d8f9d4353dcfc43f11d3 (patch)
tree11bd1d77f0b2eee5a4be6d5c8aea91e3212d7d38 /dev-python
parentdev-python/requests-kerberos: Enable python3.11 (diff)
downloadgentoo-3579b6b3c6978d0ed290d8f9d4353dcfc43f11d3.tar.gz
gentoo-3579b6b3c6978d0ed290d8f9d4353dcfc43f11d3.tar.bz2
gentoo-3579b6b3c6978d0ed290d8f9d4353dcfc43f11d3.zip
dev-python/requests-credssp: Enable python3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/requests-credssp/requests-credssp-2.0.0.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/dev-python/requests-credssp/requests-credssp-2.0.0.ebuild b/dev-python/requests-credssp/requests-credssp-2.0.0.ebuild
index 64274ccfbf94..ddc70f408253 100644
--- a/dev-python/requests-credssp/requests-credssp-2.0.0.ebuild
+++ b/dev-python/requests-credssp/requests-credssp-2.0.0.ebuild
@@ -4,22 +4,30 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="HTTPS CredSSP authentication with the requests library"
-HOMEPAGE="https://pypi.org/project/requests-credssp/ https://github.com/jborean93/requests-credssp"
-SRC_URI="https://github.com/jborean93/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://pypi.org/project/requests-credssp/
+ https://github.com/jborean93/requests-credssp/
+"
+SRC_URI="
+ https://github.com/jborean93/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~riscv"
-RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
dev-python/gssapi[${PYTHON_USEDEP}]
dev-python/krb5[${PYTHON_USEDEP}]
>=dev-python/pyspnego-0.5.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]"
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest