summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-18 17:15:49 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-18 18:04:36 +0100
commit358894f4371104dc432ce54934d8422886fe16b7 (patch)
tree2f3f0f269fad50db9246cded06ea7545d374da27 /dev-python
parentdev-python/dj-database-url: Bump (diff)
downloadgentoo-358894f4371104dc432ce54934d8422886fe16b7.tar.gz
gentoo-358894f4371104dc432ce54934d8422886fe16b7.tar.bz2
gentoo-358894f4371104dc432ce54934d8422886fe16b7.zip
dev-python/django-auth-ldap: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-auth-ldap/Manifest1
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.2.7.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
index a2e1627574ec..9f8570f3f871 100644
--- a/dev-python/django-auth-ldap/Manifest
+++ b/dev-python/django-auth-ldap/Manifest
@@ -1,2 +1,3 @@
DIST django-auth-ldap-1.2.2.tar.gz 131086 SHA256 faa067b073f6ea73c1ceeb5e244187ae1b3cf4ec79846ff366fa996428434264 SHA512 676d1114faeb9a2956ed51c586afea7618c1bf62867d3525596599391f8327b8f22a075c4203311df88279c317ca37b9097b59e55a64330afee6eb1c5a9c9ac3 WHIRLPOOL ae84405b4855ad9701244ab6cbd5e5154d2e173e04896c27e0869680bb4e030b6847293bcc59ef4f7f56969778c7d403721bae0d7099e2f3724186908c7abbbd
DIST django-auth-ldap-1.2.6.tar.gz 131385 SHA256 17671e1f0f1ef5c1242291f710956ba9446bf804ff907eab1fe533031b9411b5 SHA512 59d6d18ad2f890e26a728b9f45885d98d08d85a36bce0a28cd52e02f7c4a52def79d668c1948be37915fd0c3be72d50de983bf4a4b622ce7bbff7d3e040b63b7 WHIRLPOOL 5e673bc686f222e6704ca98f0ae8a7472bd85b6c33f3182f4a087d9a8b3174cdcd76521ce42033874979d00dee94cbdc2db5da32b8bdceb474edf3e8b498d1ee
+DIST django-auth-ldap-1.2.7.tar.gz 131431 SHA256 ff6af43d5429fbd918f62c25a07e2bff916b053b46990c1b60e60de63d5f3f80 SHA512 2ca29bdceb4b2540f7c90c9dfdfd7a02f91e72cd44ae062cebff84199dab737ee69ada56269189ec0dd70ee7916c3373acba50866280ad080c4c68dd69dffb09 WHIRLPOOL 785f1155e03f80e1c84f62bd565455c079ccf326210ff45c5597d7ac344e362b54ffb4196b1bbbdb5568a1288c053ae0dc2531489c33da95511323ea345be399
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.2.7.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.2.7.ebuild
new file mode 100644
index 000000000000..7d9afb28a589
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-1.2.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# Although setup.py claims to support py3, python-ldap does not
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="https://pypi.python.org/pypi/django-auth-ldap https://bitbucket.org/psagers/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-2.0[${PYTHON_USEDEP}]"
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/mockldap-0.2[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/docs.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH=. "${PYTHON}" test/manage.py test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}