summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-08-20 18:25:27 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-08-20 18:29:46 -0500
commit378b2af8a5e7315a3448d7b7133df3ee65045e08 (patch)
tree080301ac2387d749ff8c04058369967c2f40baac /dev-python
parentdev-libs/cdk: version bump to 5.0.20160131 (diff)
downloadgentoo-378b2af8a5e7315a3448d7b7133df3ee65045e08.tar.gz
gentoo-378b2af8a5e7315a3448d7b7133df3ee65045e08.tar.bz2
gentoo-378b2af8a5e7315a3448d7b7133df3ee65045e08.zip
dev-python/botocore: add version 1.4.46
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.4.46.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 1a0a1ee367ca..ebbf45860944 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.3.22.tar.gz 2349601 SHA256 02a6d320b09179bc5dcbafd4be732d9431bfe
DIST botocore-1.4.39.tar.gz 2646675 SHA256 e8377e312fae3f67b4e1f336a58f412f2dc9ff02117bc4a1a91ef568e6299cbe SHA512 91069671a1187968c64552f6218af8d07fe54cbcfcb8ede06c2bd5b823acc672d36205425a5370dd235028153cceb768782ae1c82fe9dffcea50a596307e7a99 WHIRLPOOL fd219954147173861f985ea2044806910f4c60c4c4ced36123a140d40f98968df5292ba1eecba99a6e6e39e71623dfa08630de46532237b503b09ac9d775f778
DIST botocore-1.4.41.tar.gz 2655741 SHA256 da37c2b9c942ff280e47122e48e1e9af827c81191da919e9c434c69e455e6a30 SHA512 ae55eacc4410ac3d6a1588395e8f2e4b857d03f2956606d4a46c430c04b57997eaff8123c0e8546601cffaeabbb3aaaec99439bd1ffa57a114fe34cb56b1a609 WHIRLPOOL b875787ce674634056ff180291d5ebc14c3d99131eff9353f7f129137224d4d6bcd86f5e8f475ade7e91e62a6498adfb2eaa5ea5c058cc8556cd554737fefc68
DIST botocore-1.4.43.tar.gz 2662274 SHA256 15e825f61170379cf0977a4f76bf75be6525f6784f9bc36e42c9c52268959283 SHA512 d65aa843efcaeb60f51b925f7f8b19ee837404a4fa4c3d36e7b7e438f3f7f1473a021f10f1b8f76ec4a8877af2967b435bd96e9384e5fa772be9ee918eaf918f WHIRLPOOL c1d2e4d12fad2365e0072d13ca59d44805c5d7dbb8d4d68c7d912cff7ffc8faf911a9553b321525e8621a9cb28cb9f99253656839e3adc0da0bbb50b60430339
+DIST botocore-1.4.46.tar.gz 2713844 SHA256 844dbd090b4127678c25342635485c87d86bca4a4f8a7c2295d715f7c830700c SHA512 f79c309ca2bc7fd8d7c2ae63b3968d7212c16d113a17fbb06938f6aeae13b92bc1645aae19258f60e61b10e9ec09868582b20fa5fc4f55a71047433b60de05be WHIRLPOOL 0d84058c1a7dcdaddcb7c2cff4c4f2a1ebe39a8db8358bfb23a50e8dbd8cebd2f30a721573d3f10e241f29e56bf82b72327fcfa17d84f423a091a23a3acc6e40
diff --git a/dev-python/botocore/botocore-1.4.46.ebuild b/dev-python/botocore/botocore-1.4.46.ebuild
new file mode 100644
index 000000000000..9c57e3342b4c
--- /dev/null
+++ b/dev-python/botocore/botocore-1.4.46.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-3.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}