summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-01 14:05:24 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-08 18:59:31 +0200
commit3951e7e64e71ea9d06c6d817b265c82c7a250a8d (patch)
tree2282d8e16ec266e7cb6270ccf47449d8b66cafc0 /dev-python
parentmedia-gfx/alembic: fix boost not found error (diff)
downloadgentoo-3951e7e64e71ea9d06c6d817b265c82c7a250a8d.tar.gz
gentoo-3951e7e64e71ea9d06c6d817b265c82c7a250a8d.tar.bz2
gentoo-3951e7e64e71ea9d06c6d817b265c82c7a250a8d.zip
dev-python/pyilmbase: Fix configure w/ >=boost-1.70
Closes: https://bugs.gentoo.org/684770 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyilmbase/pyilmbase-2.3.0.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild b/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
index fda4c62db801..f0a627779b31 100644
--- a/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
+++ b/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -38,10 +38,17 @@ src_prepare() {
}
src_configure() {
+ local boostpython_ver="${EPYTHON:6}"
+ if has_version ">=dev-libs/boost-1.70.0"; then
+ boostpython_ver="${boostpython_ver/./}"
+ else
+ boostpython_ver="-${boostpython_ver}"
+ fi
+
local myeconfargs=(
--with-boost-include-dir="${EPREFIX}/usr/include/boost"
--with-boost-lib-dir="${EPREFIX}/usr/$(get_libdir)"
- --with-boost-python-libname="boost_python-${EPYTHON:6}"
+ --with-boost-python-libname="boost_python${boostpython_ver}"
$(use_with numpy)
)