summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-21 09:26:11 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-21 09:33:31 +0100
commit3966315b2e49024ee6583249aa1b54076d194e30 (patch)
treef2695737b2e5d6af874441dc74327073d0349fd5 /dev-python
parentdev-python/astroid: Version Bump (diff)
downloadgentoo-3966315b2e49024ee6583249aa1b54076d194e30.tar.gz
gentoo-3966315b2e49024ee6583249aa1b54076d194e30.tar.bz2
gentoo-3966315b2e49024ee6583249aa1b54076d194e30.zip
dev-python/cffi: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cffi/Manifest1
-rw-r--r--dev-python/cffi/cffi-1.5.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/cffi/Manifest b/dev-python/cffi/Manifest
index 5170190a27bf..495381d82b40 100644
--- a/dev-python/cffi/Manifest
+++ b/dev-python/cffi/Manifest
@@ -1,2 +1,3 @@
DIST cffi-1.2.1.tar.gz 335778 SHA256 eab571deb0a152e2f53c404c08a94870a131526896cad08cd43bf86ce3771e3d SHA512 26ab695d34ef1895f38c735b2c6400cbf6325d622ce93799513130791365bb71d656288e991b86861ac8e899872504c1f4368d27104c4ac9b881c83c7f8dad88 WHIRLPOOL a8bbe3c24be660946c1f31fbb8b1f50810f78b9485a32aadfb091a624b5386641bde71981c58792f8e95e8e77cfce7d9959eb197c417464cf5351e568aa6336d
DIST cffi-1.4.2.tar.gz 365490 SHA256 8f1d177d364ea35900415ae24ca3e471be3d5334ed0419294068c49f45913998 SHA512 cdb265c4ae390b6498fab34a2f0920ee6eca65e6b543dfb92a0e64825bcef26e8bd4c9f1f43a15e7696128f38026e467fcdda057e00e939311a465b2b585fc34 WHIRLPOOL c3bad7b0bf27f6994bc21472f4ebadae2453e91a2e714b4801d3fb642bfdfbe838a84bc5c74a446a988629811857a28d49f3e08859c9914a385eebcf39e62f7f
+DIST cffi-1.5.0.tar.gz 385496 SHA256 44f76f6c3fc654860821785192eca29bd66531af57d09b681e6d52584604a7e7 SHA512 229b1472a54d2758ed39340a9b9d87b7d4b9d562cdb0b64276d013f11f8499c67db12e8818a3b1ff5ec0f30818a95f4c54939839d240b9545aaf4728f01c3429 WHIRLPOOL b7c7962bdde535b0be35db85525595c22d1a83bd6b35906a6f2020cc262eaa920413ae99621a784865eacf6a02f08120b9bd82301f40b3838b1afff8564e21b5
diff --git a/dev-python/cffi/cffi-1.5.0.ebuild b/dev-python/cffi/cffi-1.5.0.ebuild
new file mode 100644
index 000000000000..3220cf9234a2
--- /dev/null
+++ b/dev-python/cffi/cffi-1.5.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# DO NOT ADD pypy to PYTHON_COMPAT
+# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Foreign Function Interface for Python calling C code"
+HOMEPAGE="http://cffi.readthedocs.org/ https://pypi.python.org/pypi/cffi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc test"
+
+RDEPEND="
+ virtual/libffi
+ dev-python/pycparser[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ einfo "$PYTHONPATH"
+ $PYTHON -c "import _cffi_backend as backend" || die
+ PYTHONPATH="${PYTHONPATH}" \
+ py.test -x -v \
+ --ignore testing/test_zintegration.py \
+ --ignore testing/embedding \
+ c/ testing/ \
+ || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}