summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-09-24 18:14:30 -0700
committerZac Medico <zmedico@gentoo.org>2017-09-24 18:18:24 -0700
commit3972f7d3cfd1e7e19dde2dbd7d49d7de1810f708 (patch)
tree174f13d26cfa484aa7f17f1a129aca03ea60a160 /dev-python
parentsys-kernel/rt-sources: remove old (diff)
downloadgentoo-3972f7d3cfd1e7e19dde2dbd7d49d7de1810f708.tar.gz
gentoo-3972f7d3cfd1e7e19dde2dbd7d49d7de1810f708.tar.bz2
gentoo-3972f7d3cfd1e7e19dde2dbd7d49d7de1810f708.zip
dev-python/pymongo: version bump to 3.5.1
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pymongo/Manifest1
-rw-r--r--dev-python/pymongo/pymongo-3.5.1.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/pymongo/Manifest b/dev-python/pymongo/Manifest
index d8c22cada6cc..b10ac6513339 100644
--- a/dev-python/pymongo/Manifest
+++ b/dev-python/pymongo/Manifest
@@ -1,3 +1,4 @@
DIST pymongo-2.7.2.tar.gz 381455 SHA256 8fb45e3edec006f4b11580fc579bec7781a8b3201ce0abf31593f086070e51f6 SHA512 0e78495462d670c168e716a7c34e05f6a11a203f0bf9b32c1488608343588a48cbbb76ce715411b310359de19d9cd57c75f80ac7d8195a122a760cec22e8d0c7 WHIRLPOOL 6cb7eedc530908c2fdb17b6e31561d9c860d6fd1edddb4d66288c3fe11bc199ebc58538a70508b2540b827077f62345a86729644fdf8d37c1b9934de03e77543
DIST pymongo-2.9.3.tar.gz 433339 SHA256 1a3a75e4998a6b69d9f94c1dbac13116aee90a3f26d02f02fc0289f9e8b332c8 SHA512 7b0c46ef1ca27e8c4d99d00c764aa1ce7775503d5210513ca848215fe0be847871c6d62d14f365474606b4abfdb7d1967d3f393e545cdca8929f7fa6a497c32f WHIRLPOOL 84f6041211022326522f16e02313afbd4763f756a89d12e00714718113926ba32d3b384a22b474fe571a30b23ef49c9c1bf5f9faceb9f3d7293fd795475b5ffe
DIST pymongo-3.4.0.tar.gz 583303 SHA256 d359349c6c9ff9f482805f89e66e476846317dc7b1eea979d7da9c0857ee2721 SHA512 c59dcc08803f23134aa4a86605fab0f5c59b829325b632fc1e0149f20018a544b3d65f3c1fda6066248cd258715339b1771ca8d40c38be02c301f5b6421abd1b WHIRLPOOL c57dfa17ed0940d2ef956c2ae3dca91375b9f7fcc4e78ba3d809d838285f433141bbf8cd0a46498f1c8332e9731f6f06a40c89ba69568abe51c65c59ef03ac11
+DIST pymongo-3.5.1.tar.gz 1332463 SHA256 e820d93414f3bec1fa456c84afbd4af1b43ff41366321619db74e6bc065d6924 SHA512 67526bcc27233b85226d7ef6aacce6dfb848efc88730fb8207c3b610f3943ac813f6c2842b7e514d733a65a2b7ea4f255574732e42372551b1b333e3437fd82f WHIRLPOOL 07793cda79cfc9b8067fb7f7a491e89f757d7d0672a4b049ea94ffc2a00e39f7d08fef0872553a53da0d0034020a5b45950cf7f584ff963bb11a684fabdd5237
diff --git a/dev-python/pymongo/pymongo-3.5.1.ebuild b/dev-python/pymongo/pymongo-3.5.1.ebuild
new file mode 100644
index 000000000000..01c003201d56
--- /dev/null
+++ b/dev-python/pymongo/pymongo-3.5.1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit check-reqs distutils-r1
+
+DESCRIPTION="Python driver for MongoDB"
+HOMEPAGE="https://github.com/mongodb/mongo-python-driver https://pypi.python.org/pypi/pymongo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc kerberos test"
+
+RDEPEND="
+ kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-db/mongodb-2.6.0
+ )
+"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+reqcheck() {
+ if use test; then
+ # During the tests, database size reaches 1.5G.
+ local CHECKREQS_DISK_BUILD=1536M
+
+ check-reqs_${1}
+ fi
+}
+
+pkg_pretend() {
+ reqcheck pkg_pretend
+}
+
+pkg_setup() {
+ reqcheck pkg_setup
+}
+
+python_compile_all() {
+ if use doc; then
+ mkdir html || die
+ sphinx-build doc html || die
+ fi
+}
+
+python_test() {
+ # Yes, we need TCP/IP for that...
+ local DB_IP=127.0.0.1
+ local DB_PORT=27000
+
+ export DB_IP DB_PORT
+
+ local dbpath=${TMPDIR}/mongo.db
+ local logpath=${TMPDIR}/mongod.log
+
+ # Now, the hard part: we need to find a free port for mongod.
+ # We're just trying to run it random port numbers and check the log
+ # for bind errors. It shall be noted that 'mongod --fork' does not
+ # return failure when it fails to bind.
+
+ mkdir -p "${dbpath}" || die
+ while true; do
+ ebegin "Trying to start mongod on port ${DB_PORT}"
+
+ LC_ALL=C \
+ mongod --dbpath "${dbpath}" --smallfiles --nojournal \
+ --bind_ip ${DB_IP} --port ${DB_PORT} \
+ --unixSocketPrefix "${TMPDIR}" \
+ --logpath "${logpath}" --fork \
+ && sleep 2
+
+ # Now we need to check if the server actually started...
+ if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
+ # yay!
+ eend 0
+ break
+ elif grep -q 'Address already in use' "${logpath}"; then
+ # ay, someone took our port!
+ eend 1
+ : $(( DB_PORT += 1 ))
+ continue
+ else
+ eend 1
+ eerror "Unable to start mongod for tests. See the server log:"
+ eerror " ${logpath}"
+ die "Unable to start mongod for tests."
+ fi
+ done
+
+ local failed
+ #https://jira.mongodb.org/browse/PYTHON-521, py2.[6-7] has intermittent failure with gevent
+ pushd "${BUILD_DIR}"/../ > /dev/null
+ if [[ "${EPYTHON}" == python3* ]]; then
+ 2to3 --no-diffs -w test
+ fi
+ DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1
+
+ mongod --dbpath "${dbpath}" --shutdown || die
+
+ [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
+
+ rm -rf "${dbpath}" || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+
+ distutils-r1_python_install_all
+}