summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-10-10 11:21:03 -0400
committerBrian Dolbec <dolsen@gentoo.org>2020-10-10 14:55:59 -0400
commit3a189623d4b2179811570315f02fef39fb92691a (patch)
tree37ef40ca8cad1cebdab8f91a2016803acc0e8a5a /dev-python
parentsys-apps/xdg-desktop-portal-gtk: add keywords (diff)
downloadgentoo-3a189623d4b2179811570315f02fef39fb92691a.tar.gz
gentoo-3a189623d4b2179811570315f02fef39fb92691a.tar.bz2
gentoo-3a189623d4b2179811570315f02fef39fb92691a.zip
dev-python/treq: Version bump to 20.9.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/treq/Manifest1
-rw-r--r--dev-python/treq/treq-20.9.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/treq/Manifest b/dev-python/treq/Manifest
index 6b65bc43fc34..2b2343d60df3 100644
--- a/dev-python/treq/Manifest
+++ b/dev-python/treq/Manifest
@@ -1 +1,2 @@
DIST treq-20.4.1.tar.gz 59116 BLAKE2B 1370748d8bde407a8802d54786b45fbbc65525efba14cd5a33d741573b9fca7b36629deea65672669c4da45347bb40d975a063430ffd18f50d5ef896ce6dae66 SHA512 ca24ca7ad6bcf3fe6cba490d05eea4d71727a84bb2caf0a019edc01f91f7c25d87dc8208fc7cc816d18ef42db4dc66884475f0baa6b2cf39714e4422d0d67d3b
+DIST treq-20.9.0.tar.gz 60142 BLAKE2B a495b73221ee86163a5fefd03c8019f4b671a1f32d2ab304b89566339a36aaec7245d33b738b646fa48c42f4db9744938637ece058e067ee3f747e53ce442ab8 SHA512 c595ad69d5a9c688ca966cc897db669a57d14027e0bdc345d550f791390099743749be4a41294e61428cdc7bc0fa197474be780323b00f17a712505e081e7073
diff --git a/dev-python/treq/treq-20.9.0.ebuild b/dev-python/treq/treq-20.9.0.ebuild
new file mode 100644
index 000000000000..34acd45f6492
--- /dev/null
+++ b/dev-python/treq/treq-20.9.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="A requests-like API built on top of twisted.web's Agent"
+HOMEPAGE="https://github.com/twisted/treq https://pypi.org/project/treq/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-python/incremental[${PYTHON_USEDEP}]
+ dev-python/hyperlink[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${COMMON_DEPEND}
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18.7.0[crypt,${PYTHON_USEDEP}]
+ >=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+"
+
+DEPEND="${COMMON_DEPEND}
+ doc? ( dev-python/sphinx
+ ${RDEPEND} )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/httpbin[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ use doc && emake -C "${S}/docs" html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/ )
+
+ distutils-r1_python_install_all
+}
+
+test_instructions(){
+ ewarn "The 'test' USE flag and FEATURE only ensures that the correct"
+ ewarn "dependenciess are installed for this package."
+ ewarn "Please run eg:"
+ ewarn "$ python3.7 /usr/bin/trial treq"
+ ewarn "as a user for each of the python versions it is installed to"
+ ewarn "to correctly test this package."
+}
+
+python_test() {
+ # Tests fail when run via emerge
+ # they need proper network access
+ test_instructions
+}