summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-19 07:47:18 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-19 09:21:08 +0200
commit3c3242ab8be3f34fbd430426ae418d445ae7dd7d (patch)
treec9fc09a77103a6272670c103d66fc01edc85b853 /dev-python
parentnet-misc/chrony: Version 4.0_pre4 (diff)
downloadgentoo-3c3242ab8be3f34fbd430426ae418d445ae7dd7d.tar.gz
gentoo-3c3242ab8be3f34fbd430426ae418d445ae7dd7d.tar.bz2
gentoo-3c3242ab8be3f34fbd430426ae418d445ae7dd7d.zip
dev-python/botocore: Bump to 1.18.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.18.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index fc4a3e13d02d..03e9cf7e1a70 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.17.46.tar.gz 6738493 BLAKE2B 2e5ee1241af91c19cef0ac575c5ad68d462
DIST botocore-1.17.59.tar.gz 6829639 BLAKE2B efacd4c875e17f187abd5c4602a82229ed2a9fd78e1987f1b540eb882d1a3ce7c23768f7f4b9dc26a678ff4ce48264f3893c0aa2a68511823f79686c21ecf82f SHA512 609eb24774384b95dd9b5bcf5931d263341fbbba90b84159c6833296c22d95c6cf8d304d6908713d9ba826858d8d226e0b5c700bb1410c3a9f7b2d679f535c40
DIST botocore-1.17.63.tar.gz 6841028 BLAKE2B 89b2d5d520e733deaf3c4b68faa103e4227107cebd3803d1cb6e47ec0df9f7a07d72eb24836a45762ead2ce1aa381d5b1dfcc33eb9a80c5f8d021c0dbfb631c3 SHA512 e4cf3fbb4c8a5c05dc8265b67fbba0bf03dcf12d28bcd0e1dd304392614d86f061a5115f8129eefa2fa44efab17a8720b7c39c082c2908bf4e29bbefb57e92fb
DIST botocore-1.18.0.tar.gz 6838497 BLAKE2B efc0930b8ffafdf8d7f24d4f30cbf12e0dd81aa4ae405beee7663271fe8ffe680df91d40f8629b75635fae87ad29f0186e42f11e4bfebc64cc58979edd74e64b SHA512 43b5992d1ffb8d10f32f532c3085825e3775e3da4d6c25c2e300dfcd6e24967bdd318a7be37889a9d7802eb74bd9085b9642cda099b0064cbd9ffd65a56b7de5
+DIST botocore-1.18.1.tar.gz 6839699 BLAKE2B 188c5a05345fc7c4d4c05b3a8d9b675b5c2141326caa62f9ae8a5a996f6c7ff4e56c581fd010afbc4c57073d7b6efd22debad3e03456f6ad0453c7f823d6409e SHA512 63a9a7ac93a8774d7a1a511da0464d7b5d0841598c7358e97343406b4d76842ca56a0187ff173e0a29d9da9ee22f94fde66f4b8c3e9c8a3fbcabdaddbe95b752
diff --git a/dev-python/botocore/botocore-1.18.1.ebuild b/dev-python/botocore/botocore-1.18.1.ebuild
new file mode 100644
index 000000000000..ba67bf7ac94b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.18.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}