summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 15:10:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 15:41:03 +0200
commit402c1607ca916a7b7ca5a00ce775f3304d344034 (patch)
treef83d50a5de48d9ad831c0b65b95212f23aeb3c31 /dev-python
parentdev-python/cli_helpers: Enable py3.10 (diff)
downloadgentoo-402c1607ca916a7b7ca5a00ce775f3304d344034.tar.gz
gentoo-402c1607ca916a7b7ca5a00ce775f3304d344034.tar.bz2
gentoo-402c1607ca916a7b7ca5a00ce775f3304d344034.zip
dev-python/snapshottest: Enable py3.9 & py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/snapshottest/snapshottest-0.5.1.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/dev-python/snapshottest/snapshottest-0.5.1.ebuild b/dev-python/snapshottest/snapshottest-0.5.1.ebuild
index aec16c0b697d..c49cc1e8330a 100644
--- a/dev-python/snapshottest/snapshottest-0.5.1.ebuild
+++ b/dev-python/snapshottest/snapshottest-0.5.1.ebuild
@@ -1,10 +1,9 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..8} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
# no tests on pypi, no tags on github
@@ -13,24 +12,21 @@ COMMIT_HASH="4ac2b4fb09e9e7728bebb11967c164a914775d1d"
DESCRIPTION="Snapshot Testing utils for Python"
HOMEPAGE="https://pypi.org/project/snapshottest/
https://github.com/syrusakbary/snapshottest"
-SRC_URI="https://github.com/syrusakbary/${PN}/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+SRC_URI="
+ https://github.com/syrusakbary/${PN}/archive/${COMMIT_HASH}.tar.gz
+ -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT_HASH}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
dev-python/termcolor[${PYTHON_USEDEP}]
"
-BDEPEND="${RDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
+
+distutils_enable_tests pytest
PATCHES=(
"${FILESDIR}/snapshottest-0.5.1-remove-fastdiff.patch"
@@ -44,6 +40,6 @@ python_prepare_all() {
python_test() {
distutils_install_for_testing
- pytest -vv tests examples/pytest || die "Tests failed with ${EPYTHON}"
+ epytest tests examples/pytest
"${EPYTHON}" examples/unittest/test_demo.py || die "Tests failed with ${EPYTHON}"
}