summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2018-05-27 14:28:51 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-07 10:16:33 +0200
commit40c5fd43c476a7d755c4b985bd8d0a3a786a11df (patch)
treeb83ba39e057d46ba7916f7ed59bf4f32c36f9ab1 /dev-python
parentprofiles/base: Use-stable-mask sys-devel/clang-runtime[crt] (diff)
downloadgentoo-40c5fd43c476a7d755c4b985bd8d0a3a786a11df.tar.gz
gentoo-40c5fd43c476a7d755c4b985bd8d0a3a786a11df.tar.bz2
gentoo-40c5fd43c476a7d755c4b985bd8d0a3a786a11df.zip
dev-python/django-tagging: bump to 0.4.6, add doc, fix deps
Also add GitHub upstream to metadata.xml. Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-tagging/Manifest1
-rw-r--r--dev-python/django-tagging/django-tagging-0.4.6.ebuild36
-rw-r--r--dev-python/django-tagging/metadata.xml1
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/django-tagging/Manifest b/dev-python/django-tagging/Manifest
index fa3cc9e54f6a..d61fb80ab373 100644
--- a/dev-python/django-tagging/Manifest
+++ b/dev-python/django-tagging/Manifest
@@ -1 +1,2 @@
DIST django-tagging-0.4.1.tar.gz 44260 BLAKE2B 44d39d44892fa86ebc4ea185fb53696be772738a60a29d121d883ed3f123914a4621701c2a1efc4b0e309cd02ad0f7d28fb468eeff15c1b147724e8f9dc36e9b SHA512 6f6899084fd5067ec2e49649bba4aad225ed738f39f999b7ea5156d38fa28c272d4a1f688d4de712db15fe8f2c2ecfd4532eb6e9c0c1de6dd530c09d7d767a26
+DIST django-tagging-0.4.6.tar.gz 45228 BLAKE2B 77ed033ad61d227f8fea9e794b888da5d3a81474330d56bbbbcb1ce457ecac27d9615decadaece3c8b8fd2864c53342b795e8a76528c42609b928624609ccabe SHA512 75abf4b57df52393c8eb1ea265344c90c48b4225151076ce874b2e43657dd6cf4fffa1149acc2e118d58e3701d18103a362f658ce5114d7f207a33e7f4903b38
diff --git a/dev-python/django-tagging/django-tagging-0.4.6.ebuild b/dev-python/django-tagging/django-tagging-0.4.6.ebuild
new file mode 100644
index 000000000000..fc37602ad780
--- /dev/null
+++ b/dev-python/django-tagging/django-tagging-0.4.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic tagging application for Django"
+HOMEPAGE="https://pypi.org/project/django-tagging/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-python/django-1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ sed -i "/sphinx.ext.intersphinx/d" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
diff --git a/dev-python/django-tagging/metadata.xml b/dev-python/django-tagging/metadata.xml
index 1410662a219f..765895e8be7d 100644
--- a/dev-python/django-tagging/metadata.xml
+++ b/dev-python/django-tagging/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="pypi">django-tagging</remote-id>
+ <remote-id type="github">Fantomas42/django-tagging</remote-id>
</upstream>
</pkgmetadata>